1

I've been bugged by my laptop going into a disk check at every powerup, and I think I have figured out why.

My root partition is ext2 (I chose it when I set the laptop up, and I haven't wanted to risk updating it to ext3). When I run 'dumpe2fs', it shows the last mount time was over a month ago (which I think may be triggering the disk check), whereas, strangely the last write time was today.

I've already run the disk check tool -> SMART Data and Tests -> Self Tests, and that doesn't bring up anything bad.

Why could my mount time be wrong, and how do I fix it?

Thanks

1

First thing to check would be the hardware clock in the bios. The hardware clock keeps the current time and date even when the system is shut down, however, if it is not working properly, then this could cause problems.

  • Power on the laptop, but instead of booting Linux, go into the BIOS.
  • On the first bios panel there is usually a day-date setting.
  • If the system boots Windows as well as Linux then the time should be your local time.
  • If the system is Linux only, then the time may be UTC.
  • You may need to repeat this check a few times order a period of days because it may be affected by your laptop battery as well as a button cell inside the laptop.

If the hardware clock is not working correctly, that will likely be the cause of the disk checks, because the Linux system clock is set initially from the hardware clock, but then is adjusted forward after your laptop connects to the network, confusing e2fsck.

  • Greg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.