Here is my story: 1. I plugged an external VGA monitor to my laptor (Dell Vostro 3550) and configured dual display using System Settings/Displays. Everything worked well 2. I unplugged the external monitor, switched off my laptop and left my office 3. Being at home, when I turn on my laptop I get a blank screen on my LCD display. Ctrl+Alt+F1...F7 doesn't work. I assume that my primary display is still set to the external monitor, but I don't have any external monitor at home. How can I switch back to LCD?


A quick and dirty method

  1. Boot into recovery
  2. Select 'root'
  3. Remount root partition as writable
    • mount -o remount,rw /
  4. Backup, but remove your xorg.conf
    • mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
  5. Reboot

Plan ahead

Do some research on Disper and see if it can ease your monitor woes once you've gotten back on your system. You might find this post informative.

|improve this answer|||||
  • Today I tried plugging back the external monitor - it didn't help, both monitors were black. I have found out that this problem occurs only with kernel. If I boot with the previous kernel, all monitors work fine. Can it have anything to do with xorg.conf? – pgorecki Apr 12 '13 at 18:22
  • Actually, it sounds like your drivers haven't been re-compiled for your new kernel. Have you installed your gfx drivers manually? Are you using ATI, nVidia, or Intel? – earthmeLon Apr 12 '13 at 18:26
  • I didn't instally any drivers - I'm using the ones shipped with Ubuntu. This laptop has a hybrid graphics. That's what lspi | grep VGA gives: 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series] The boot behaviour is unpredictable. Sometimes have to use the old kernel, sometimes everything works fine with the new kernel. – pgorecki Apr 16 '13 at 17:02

I use Ubuntu 16. Before disconnecting the external monitor, you could go to display settings and manually turn off the external one. Then try to disconnect. Works for me.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.