6

if i enter "vim" in unity search (after pressing Super key") nothing shows up.

I can only start gvim by using Alt+F2 and entering gvim. Why does this happen?

4

This seems to have solved the problem for me:

sudo cp /usr/share/app-install/desktop/vim-gui-common\:gvim.desktop /usr/share/applications

This was suggested by a related bug report.

2
  • Does the trick. – Serrano Pereira Aug 9 '13 at 19:03
  • This only worked for me if I escaped the colon: sudo cp /usr/share/app-install/desktop/vim-gui-common\:gvim.desktop /usr/share/applications/. I also like the ending slash, just so you know it is a directory. – ryanpcmcquen Aug 18 '15 at 14:14
2

This worked for me:

cp /usr/share/app-install/desktop/vim-gui-common\:gvim.desktop ~/.local/share/applications/gvim.desktop

Explanation:

Copy & rename vim-gui-common:gvim.desktop to gvim.desktop in your user directory, to make it available.

Add it to the launcher

Drag ~/.local/share/applications/gvim.desktop to your launcher

The other answer (copy to /usr/share/applications) didn't work here in 14.04.

0
1

I'm looking at this about a year later, using Ubuntu 16.04. I wasn't able to find any useful "vim" results in Unity search. I used Ubuntu Software to install the "gvim" package and it just did everything for me, including putting the shortcut with the correct icon into the Unity toolbar.

0

You can install icon using sudo apt-get install vim-gui-common. Icon appears after a reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.