I'm trying to install the File System Visualizer (think "It's a UNIX System! I know this!" from Jurassic Park) on Ubuntu 10.10.

I've got the .tar.gz downloaded, and extracted. However, when I ./configure, I get this output:

loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... missing
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for ranlib... ranlib
checking for POSIXized ISC... no
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for ANSI C header files... yes
checking whether time.h and sys/time.h may both be included... yes
checking for strings.h... yes
checking for sys/time.h... yes
checking for unistd.h... yes
checking for working const... yes
checking for mode_t... yes
checking for uid_t in sys/types.h... yes
checking for pid_t... yes
checking for size_t... yes
checking for comparison_fn_t... yes
checking for st_blocks in struct stat... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for working alloca.h... yes
checking for alloca... yes
checking for working fnmatch... yes
checking for strftime... yes
checking for getcwd... yes
checking for gettimeofday... yes
checking for mktime... yes
checking for strcspn... yes
checking for strdup... yes
checking for strspn... yes
checking for strtod... yes
checking for strtoul... yes
checking for scandir... yes
checking for inline... inline
checking for off_t... yes
checking for unistd.h... (cached) yes
checking for getpagesize... yes
checking for working mmap... yes
checking for argz.h... yes
checking for limits.h... yes
checking for locale.h... yes
checking for nl_types.h... yes
checking for malloc.h... yes
checking for string.h... yes
checking for unistd.h... (cached) yes
checking for sys/param.h... yes
checking for getcwd... (cached) yes
checking for munmap... yes
checking for putenv... yes
checking for setenv... yes
checking for setlocale... yes
checking for strchr... yes
checking for strcasecmp... yes
checking for strdup... (cached) yes
checking for __argz_count... yes
checking for __argz_stringify... yes
checking for __argz_next... yes
checking for stpcpy... yes
checking for LC_MESSAGES... yes
checking whether NLS is requested... yes
checking whether included gettext is requested... no
checking for libintl.h... yes
checking for gettext in libc... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for gtk-config... no
checking for GTK - version >= 1.2.1... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error: Cannot find proper GTK+ version

Obviously it's looking for gtk-config. However, apparently it doesn't exist in the repos anymore. Then this post mentioned that gtkglarea solved their problem, as mentioned in this file.

Of course that poster neatly forgets to mention exactly what and how gtkglarea solved their problem, and Google is mostly devoid of information on the problem.

So I come here asking for help! I would like to install fsv, but it tells me gtk-config doesn't exist. How can I fix this problem in Ubuntu 10.10?



So with the help of Robert, this is what I had to do:

From the Dapper repositories I downloaded:


then I had to install:

  1. libglib1.2
  2. libglib1.2-dev
  3. libgtk1.2-common
  4. libgtk1.2
  5. libgtk1.2-dev
  6. gtkglarea5
  7. gtkglarea5-dev

I used sudo gdebi <file>.deb for most of them (it tells you dependencies better, if you missed one). In a few cases, gdebi does not do the right thing, and dies. When this happens, use dpkg -i <file>.deb and it should work.


If the library is still used or wanted by someone, how can it be obsolete??

I had the same problem building mozilla 1.7.13 (yes, the old mozilla browser).

I've got round this in 10.10 manually installing the dapper package and all dependencies:


you'll need:

  • When trying to install libgtk1.2-dev_1.2.10-18_i386.deb I get a Breaks existing package 'libgtk1.2' that conflict: 'libgtk-dev'. error. Any clues on how to fix that? Google turns up nothing. May 13 '11 at 14:10
  • Ah - apparently gdebi is stupid sometimes. Using dpkg -i installed it. Looks like I've got another need - configure: error: Cannot find gtkglarea. To the Google! May 13 '11 at 14:20

There is an updated version of fsv to be found on GitHub: https://github.com/mcuelenaere/fsv. It has been modified to work with GTK 2.0 and works for me on Linux Mint 13 (using Ubuntu 12.04 packages)


that software is unmaintained and requires GTK1 which is an obsolete graphical library version, it is not available from the Ubuntu repositories and I am not aware of any repository providing it.

I would recommend you to contact the software author and check with him if there is an upgrade planned, or otherwise search for a maintained similar software.

  • no such thing as similar maintained software. Well, there are other 3d-style, but saying they're similar is like saying the ENIAC and your computer are similar because they both operate in binary. As the last modification was made in 2001, I highly suspect there will be no updates soon... Feb 25 '11 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.