2

Basically the system won’t boot. After the BIOS screen I get the message: “Error 1692: No operating system found”

I ran the ‘boot-repair’ utility without success. Here is the boot info that utility generated:

http://paste.ubuntu.com/5695250/

Everything looks correct as far as I can tell. I booted a liveCD, mounted /dev/sda1, and poked around the “EFI” directory. Everything looks correct in there also. Here is a pastebin for the commands I ran there:

http://paste.ubuntu.com/5695339

Does anyone have any idea how to fix this situation? I've been through all the options in the BIOS and nothing seems to help. I noticed this message from 'boot-repair'

"Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/grubx64.efi file"

However, I do not see any options in the BIOS startup for selecting which option to boot from.

1

Try this command from a Linux EFI-mode emergency boot:

efibootmgr -o 3

Note that's a lowercase letter -o in the command.

If that doesn't work, then your firmware is broken, and I recommend the following:

  1. Mount your ESP (/dev/sda1) somewhere convenient (say, /boot/efi).
  2. cd to /boot/efi/EFI.
  3. Type sudo rm -r Microsoft. (This assumes that you do not have a Windows installation on the computer. If I'm mistaken in this, then do not perform this step.)
  4. Type sudo mv boot boot-old.
  5. Type sudo cp -a ubuntu boot.
  6. Type sudo mv boot/grubx64.efi boot/bootx64.efi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.