Just tried to upgrade my ubuntu 10.10 using "do-release-upgrade" from console and fails: Error is:

alex@spse:/# do-release-upgrade
Checking for a new ubuntu release
Get:1 Upgrade tool signature [198B]
Get:2 Upgrade tool [1306kB]
Fetched 1307kB in 0s (0B/s)
authenticate 'natty.tar.gz' against 'natty.tar.gz.gpg'
exception from gpg: GnuPG exited non-zero, with code 2
Debug information:
gpg: Signature made Mon Jun  4 09:40:31 2012 EDT using DSA key ID 437D05B5
gpg: Can't check signature: public key not found
Authentication failed
Authenticating the upgrade failed. There may be a problem with the network or with the server.

Any ideas?

Thanks, Alex

  • Are you using the old-releases server? Also, what's your ultimate goal? If you can specify that, it might be possible for alternative methods to be suggested. – Eliah Kagan Apr 10 '13 at 11:13
  • See this question: GPG can't check signature... Run the commands using the key appropriate for you, ie: replace 7ADF9466 with 437D05B5 when you run the commands. – Aditya Apr 10 '13 at 12:29
  • Just tried using old-releases server. no luck. my goal is to upgrade to 12.04 lts; i wish to avoid a clean install. Also just tried your method Aditya - still no luck; – Alex Trandafir Apr 10 '13 at 12:54

You tried to update to natty (11.04) but 11.04 is EOL since October 28, 2012.
Take a look at this page: https://wiki.ubuntu.com/Releases

This is why you can't upgrade - the package you request doesent exist any more.

I think you have to reinstall with an actual Ubuntu-Version (12.04 or 12.10). Or 13.04 which will be released at the End of April.

  • The 11.04 download do still exist, they've just been moved to old-releases.ubuntu.com. natty.tar.gz exists and was downloaded, so the OP is most likely using that server, though I'm hoping the OP will clarify explicitly. Since some files exist, I don't think there's a trivial explanation for why other files, or other information, is unavailable. (I'm also not sure this usually happens when people try to perform an EoL upgrade like that.) – Eliah Kagan Apr 10 '13 at 11:08
  • You say I can't upgrade? – Alex Trandafir Apr 10 '13 at 11:13

Using Eliah Kagan link then command:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 437D05B5 3E5C1192

do-release-upgrade seems to work;

Even so, I don't know how safe it is to upgrade over ssh.
My current config is: ubuntu 10.10 installed on physical disk, and booted with vmware-player from windows 7.

Any ideas/suggestions?

Thanks, Alex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.