I have found several posts similar to mine, but this is the closest matching one to my specific issue: USB Keyboard works occasionally. I am not sure if the answer given there would work for me, because I didn't entirely understand what needed to be done. I'm still new to Linux.

---------- The Issue In Short:

I have a laptop where the mouse and keyboard both fail to function once it has booted into Ubuntu. This has been happening since day one (initial Ubuntu install), but it used to be a rare occurrence. Now (for the last few weeks), it has gotten worse, moving from happening once every ~20 boot ups, to easily happening 30 boot ups in a row.

---------- Machine Details:

  • I'm using a Toshiba Satellite L875D-S7230.
  • The default Windows 7 install has been untouched, but the partition has been scaled to make room for Ubuntu.
  • I have an up to date install of Ubuntu 12.10, setup to duel boot with the default Win7 install.
  • The Linux wifi driver had to be compiled and installed manually. (whole different issue)
  • I am using the proprietary video card driver that came pre-installed with Ubuntu.

Hibernation is disabled to prevent the computer from locking up. (a common problem I've read). The computer can't reboot properly, I have to always shut it down. (not an issue I'm concerned with right now)

---------- Problem Details:

The built in keyboard and mouse both fail when Ubuntu loads. The failure seems to be instant, as I do not have the ability to move the mouse or type any keys from the moment I see a cursor appear on screen.

The keyboard doesn't respond in any way. Pressing Num-Lock, Scroll-Lock, or Caps-Lock does not make any of the indicator lights turn on.

The only button on the laptop that seems to do anything is the power button, which allows me to hard boot the machine.

The only USB device I own to assist in troubleshooting is a mouse. Luckily, it has worked every time I plug it in. It has never failed, and is currently the only way I can turn off the laptop without hard booting it. I only plug in the mouse when the built in mouse and keyboard fail.

The mouse and keyboard both work perfectly under Win7, and the keyboard works perfectly when GRUB loads. The failure only happens when I select Ubuntu and the OS begins to load.

If anybody can help I would greatly appreciate it. I'm not sure what the issue could be, and my laptop is almost unusable at present.

  • Although this seems to be fixed, I would like to point out that closing and opening the lid while stuck at the log in would make Ubuntu try again to detect the keyboard and mouse. This usually worked on the first try, but sometimes took up to three or so attempts. After upgrading from 12.10 to 13.10, this no longer worked. 13.10 seems to handle sleeping and hibernating differently, and in 13.10 I lost video completely after closing the lid at the log in screen. If anyone else is having similar issues I hope this helps. :-) – RoboticForest Mar 13 '14 at 5:13

I have exactly the same laptop and searching on the web this is what I found to solve the problem:

1) Run the following command in terminal

sudo nano /etc/default/grub

2) Locate the following section in the file:


Replace it with:

GRUB_CMDLINE_LINUX="i8042.nomux=1 locale=fr_FR i8042.reset"

3) Save the file and exit nano.

4) Run the following command in terminal:

sudo update-grub

5) Restart your computer.

Now everything should work fine.

| improve this answer | |
  • Thank you very much for answering! :-) If I'm understanding this correctly, GRUB_CMDLINE_LINUX is a string of arguments to the Linux kernel as it is being initialized? Also, the arguments bypass the kernel's attempt to detect an input feature some computers have? Explained here – RoboticForest Mar 13 '14 at 3:39
  • I implemented the change (minus setting the locale to France) and so far so good. I've rebooted my computer about a half dozen times without any problems. I'm hoping this isn't a fluke (had that recently), but if this keeps working, THANK YOU! :-D – RoboticForest Mar 13 '14 at 5:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.