Is there any way to get ubuntu to recognise an ATI 6950? I have tried installing the proprietary ATI drivers, but these do not seem to work properly. It seems to screw up the gnome desktop, and starts booting into terminal. I'm somewhat of a linux newbie, so not really sure whats going wrong. I don't want to game on ubuntu, I just want it to recognise my dual monitor setup rather than mirroring the monitors, so any driver that does this is fine by me.

It seems like the open source ATI radeon drivers will not support the 6950/6970 for some time, at least until kernel 2.6.38 is released.

The card is also flashed with the 6970 firmware, not sure if this is important. I am running a 64 bit version of ubuntu, I installed ubuntu server 10.10, then installed gnome-desktop.

  • which kernel version are you using? you can do a uname -r when it boots into the terminal screen. if you are running 2.6.35-25, then you are not alone. There are many ATI users that seems to have the same problem with 2.6.35-25. Post your /var/log/Xorg.o.log for more help. If you are indeed running 2.6.35-25, a possible temporary solution is to install 2.6.35-24, and boot with this kernel. It works for me anyway.
    – hansioux
    Feb 25 '11 at 15:23
  • May I ask if 3D accelaration works on your system perfectly?
    – user13741
    Apr 6 '11 at 19:03
  • Im not sure. I have given up on ubuntu as it keeps forgetting my screen configuration and I have to reconfigure it every time I boot. I still have ubuntu installed, so if you have any specific tests I could do to test if 3D acceleration works I am happy to try and report back.
    – aj.esler
    Apr 7 '11 at 4:31

I have found a solution. The wiki page here describes a process for installing the ATI drivers. So in the end, the steps I took were:

  1. Install Ubuntu Server 10.10
  2. Install ubuntu-desktop package
  3. List item
  4. Restart
  5. Follow the instructions on the wiki page linked above, stopping when you get to the EDIT: STOP! line.
  6. Restart
  7. open ATI catalyst control center in administrative mode.
  8. Set the monitor resolutions and configurations via the display manager tab. I tried several methods to set the resolution, but the only one that actually worked was go to each monitor's Multi-Display tab, and set the value to Multi-display desktop with display(s) 2, and then use the arrow that appears in the image in the monitor layout window at the top to select the resolution of each monitor.
  9. Restart

You could try these two commands in the terminal:

glxinfo | grep rendering



I'd like to see the output if possible.

  • The output is as follows @Tesseract: ~$ glxinfo | grep rendering direct rendering: No (LIBGL_ALWAYS_INDIRECT set) ~$ glxgears Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate. 27801 frames in 5.0 seconds = 5558.008 FPS 24680 frames in 5.0 seconds = 4933.043 FPS 19420 frames in 5.0 seconds = 3881.187 FPS 19790 frames in 5.0 seconds = 3955.676 FPS 19720 frames in 5.0 seconds = 3940.805 FPS
    – aj.esler
    Apr 11 '11 at 5:46
  • arg!, can't format output nicely.
    – aj.esler
    Apr 11 '11 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.