0

I'm using Ubuntu 12.10 on an Asus EEEPC 1015PN. This netbook has an Nvidia Ion GPU, which I had to install Mtrons scripts in order to use (located here: https://sites.google.com/site/mtrons/howtos/eeepc-1015pn). These worked great at first and I much prefer the Nvidia mode for Steam and Minecraft and other gaming.

However today I tested out the Intel mode and it also works great. But I restarted in order to go back to the Nvidia mode and it doesn't boot to the window manager, instead it just drops me into tty1. The only way I can get to a GUI is by using the Intel mode and now I'm basically stuck in Intel mode. I tried restarting many times and also have tried the commands from Mtron's script such as sudo display-settings auto and sudo display_settings fix and also sudo display-settings config-nvidia. None of those worked. I can't seem to get to the GUI. I would appreciate some advice if anyone has encountered this problem. Thank you very much.

  • Please give us output of sudo lspci | grep VGA. – Misery Apr 9 '13 at 9:43
  • 00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (rev 02) – Pat Apr 9 '13 at 9:48
  • Could you please put here an information if anything is written in 7th terminal? ( Alt+Ctrl+F7 ) If not then please write start x and let us know what is the output – Misery Apr 9 '13 at 9:59
  • everything is normal but there are a couple lines that talk about the GPU issue. For example at the top it says: Starting Bumblebee supporting nVidia Optimus Cards [fail] then a bunch of [OK]s and further down it says No suitable module for kernel found [fail] and the last one further down after a few [OK]s says Starting load fallback graphics devices [fail] Sorry if this doesn't help, I wasn't sure what to write exactly – Pat Apr 9 '13 at 11:09
  • try to generate Xorg.conf file (sudo Xorg -configure) and put the output here. Path to this file will be prompted to the screen. – Misery Apr 9 '13 at 11:14
0

This should have been a bugreport and not a question suitable for this site but well, here we are ;) Next time, use the integrated "report a bug" wizard in the gui. So we can make sure bug reports reach me.

This bug happened because the driver naming schema for the nvidia binary driver package changed from 'nvidia-current' to nvidia-< first 3 digits of driver version>. The scripts are updated now and work with the new schema, so update to the latest version (assuming you already added the ppa run sudo apt-get update && sudo apt-get dist-upgrade ) and run

sudo display-settings regenerate-glx 

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.