I update Ubuntu 12.10 with Kernel 3.5.0-27 today march 9 2013 (I had the past kernel 3.5.0-25). But not I cant use VirtualBox 4.2.10-84104, appears me this erre message:

VirtualBox Error Details

Code Result: NS_ERROR_FAILURE (0x80004005) Componente: Machine Interfaz: IMachine {22781af3-1c96-4126-9edf-67a020e0e858}

And another window that say:

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

I run these commands in the terminal:

sudo apt-get install dkms and done dkms is already the newest version but with the next command, appears me

sudo /etc/init.d/vboxdrv setup Error! Your kernel headers for kernel 3.5.0-27-generic cannot be found. Please install the linux-headers-3.5.0-27-generic package, or use the --kernelsourcedir option to tell DKMS where it's located

  • Failed, trying without DKMS
  • Recompiling VirtualBox kernel modules
  • Look at /var/log/vbox-install.log to find out what went wrong

What can I do??? thank you very much in advance the answer


1 Answer 1


I had the same problem. I just installed the kernel-headers from here:


After I installed the headers, I opened the terminal and typed:

sudo /etc/init.d/vboxdrv setup

It worked after that.

  • What is the difference here to just apt-get install linux-headers-generic ?
    – guntbert
    Apr 13, 2013 at 21:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .