Okay so, there are 2 computers in my house (apartments), one desktop and one laptop (mine, the issue). The desktop is brand new, my fiancee uses it daily and it runs windows 8; mine is running ubuntu 12.04 LTS with gnome shell installed. The windows computer is plugged into the modem and gets it's internet from that, but my laptop gets it wirelessly, which is the problem. Here's a little back story: I had windows 7 installed not even 5 days ago and the wireless was working fine. The only time my laptop didn't have internet was when the other computer wasn't getting it either (which was rare). But after installing ubuntu (before and after tinkering (adding drivers, gnome shell, my apps, etc.)), it cuts in and out every few minutes; though it can last a while, it isn't predictable. I've looked up ways to fix it and none seem feasible to me, though it could just be my inexperience with this sort of thing. If specs are needed, I'm gonna need someone to tell me how, as that's how little I know about this. Any help would be appreciated at this point, I really don't want to go back to windows but right now it looks like it's the only option. I'll wait a while for replies but if I can't fix it soon I may need to stop trying to use ubuntu altogether. Any help is appreciated. Thanks in advance. EDIT: I've noticed two things since posting this, one is that even when my computer is plugged in to the ethernet, my internet is still cutting out; and two is that when I'm online (I use google chrome) I get a error saying that there was a problem, that usually but doesn't always appear underneath my web browser window after it fails to connect to the DNS server.


I had this issue several times, mostly the problem is because you don't have the necessary drivers installed. Also, you may improve the connection speed by disabling IPv6.

Disabling IPv6: Go to the Network menu and click on the "Connection Information" menu. If there's nothing under the IPv6 box, you can safely disable IPv6.

Installing Wireless N drivers: If you use a Wireless N device (which may be the case), you should install the wlan-ng drivers (you can search them in the Software Center).

| improve this answer | |
  • Alright! Thank you for your excellent help Alex! I just found the files in Synaptics and installed them because software center wasn't finding them. Then I restarted my computer and now I can load any of my bookmarks within a couple seconds now! :) Is there a trial period I should lend to this? Or can I chalk it up as fixed permanently? And if I can consider it fixed, how do I mark this as solved for others to see? – Michael Apr 9 '13 at 16:57
  • I think it should be fixed permanently, the only times that your drivers may suddenly stop working is when you update your kernel (which generally happens only when upgrading to another Ubuntu version, say from 12.04 to 12.10). By the way, I'm glad it worked for you! – Alex Spataru Apr 9 '13 at 17:37
  • Problem is not solved, though it's not as bad as it was. Just had to restart because my previous method of turning wi-fi off then on didn't work. It worked well for a while, any ideas why it's wtill happening? – Michael Apr 9 '13 at 19:25
  • Okay, I'm testing a wired connection and there seems to be the same problem with that as well...? This isn't making any sense anymore. – Michael Apr 9 '13 at 20:34
  • Does the Windows PC have any problem with the connection? – Alex Spataru Apr 10 '13 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.