92

I want to disable the way the microphone lowers itself depending on the input. Here is an image:

enter image description here

The microphone started at 100% and slowly started to drop to where the image is showing. This is because of either a background noise or the user raising their voice. In any case, I would like to prohibit this behavior because when it gets too low, the need to raise the voice will be actually needed.

So is there an option or configuration file where one can edit and change this behavior?

This is not related to only one app but several, ranging from Skype to Google Hangouts, Empathy to Teamspeak and more. So please no answers mentioning only one app if the solution does not solve the problem for others.

the pulseaudio app (gui and terminal) was already used. Alsamixer was also used. In both cases, adjusting the microphone level did not help. The auto adjust always happens when anyone speaks, does not even need to be someone speaking loud, they just need to speak and after a couple of seconds the mic level will start auto adjusting. I repeat, this is not a 1 app problem but several, so a common solution is better than a 1 for each app (Which we are talking about more than 50 apps).

3

10 Answers 10

40

Not sure if this applies to everyone, but if you use any kind of web conference / video chat service in Chrome / Chromium such as Google Hangouts, there's a good chance it uses the WebRTC protocol. Unfortunately the WebRTC implementation in Chromium comes with a handy “feature” called Automatic Gain Control that tends to screw with your microphone volume. Unless the web app itself gives you an option to disable it, there is otherwise no way turn it off, and Chrome developers don't want to add a global “off switch” for it.

What I ended up doing was to use @lelandbatey's solution. Since I was using PulseAudio, I used pacmd instead of amixer:

while sleep 0.1; do pacmd set-source-volume alsa_input.???-?????.analog-stereo 90000; done

Note that 65535 corresponds to 100%, so 90000 is about 135%. The name of the device (alsa_input.???-?????.analog-stereo) should be substituted with whatever you find by running pacmd list-sources | grep name::

name: <alsa_input.???-?????.analog-stereo>
3
  • If AGC didn't suck so much I wouldn't mind. But it adjusts my internal mic until you can hear the fan like a jet engine no matter what I do. Sigh. Might have to run web based video conferencing through firefox because of this. Apr 29 '17 at 0:03
  • 1
    Somebody made an open source extension Disable Automatic Gain Control for Chromium based browsers that fixes this. It's open source (code here). This is what I'm using now and it works very well. Maybe you can add it to your answer to make it more prominent?
    – nh2
    Jan 16 at 18:21
  • I used this technique and it works very well, but the CPU usage increases a lot because of the loop May 20 at 20:08
24

For Skype:

Skype > Options > Sound devices
and Uncheck Allow skype to automatically adjust my mixer level

1
  • There is similar option in zoom . Setting -> Audio -> Uncheck "Automatically adjust microphone volume". My issue is resolved this way. Oct 8 at 7:23
15

This worked for us (we're not using Skype):

Disable auto adjusting of gain on mic:

  1. Edit as root: sudo editor /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
  2. Edit as root: sudo editor /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf
  3. Under "[Element Internal Mic Boost]" set "volume" to "zero".
  4. Under "[Element Int Mic Boost]" set "volume" to "zero".
  5. Under "[Element Mic Boost]" set "volume" to "zero".
4
  • after restarting stopped working :c Oct 21 '19 at 16:51
  • Similar answer: askubuntu.com/questions/689209/…
    – nh2
    Nov 6 '19 at 0:25
  • By default this file is not available to have it on system use sudo apt install pulseaudio
    – 4xy
    Mar 22 at 17:22
  • I tried a lot of solutions that did not work. But this one did work. Sep 17 at 15:32
11

Set your microphone to Unamplified 100% Try installing pulse audio volume control:

sudo apt-get install pavucontrol

And then open: pavucontrol

6
  • First for skype, "Skype" -> "Options" -> "Sound devices" -> Uncheck "Allow skype to automatically adjust my mixer level". Second in pavucontrol ->"Input Devises" set level to "Base"
    – burtsevyg
    Sep 15 '15 at 20:17
  • 5
    Where in pavucontrol can I set that?
    – golimar
    Jan 28 '20 at 15:58
  • 5
    Using this app I can see the microphone's slider jump on its own. I can manually move it around, but some minutes later it jumps back. Oct 6 '20 at 6:53
  • @PaŭloEbermann were you able to fix it?
    – krionz
    Feb 27 at 1:08
  • @krionz Somewhat. With more googling at some other places I found that's some functionality of Chromium which tries to adjust the input volume when someone is talking. Chromium devs think it's Google Hangout's/Meet's job to disable this, and I guess Google Meet devs don't care. So I basically used Rufflewind's answer to just reset the input volume all the time.. It did get better when I got a new computer in December, with where the basic volume settings are completely different, so I didn't need to do this since then. Feb 27 at 20:01
8

The answer from this "duplicate" question is for me the best, I let the credits to the person who answered

In the configuration file /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf (you might have to look for the correct file for your microphone), I changed the volume = part to 100 which is the percentage instead of merge

[Element Capture]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

to

[Element Capture]
switch = mute
volume = 100
override-map.1 = all
override-map.2 = all-left,all-right

and after a sudo alsa force-reload, applications don't magically change the microphone volume anymore.

3
  • This didn't work for me. Input volume still lowers when a loud sound is encountered.
    – Cerin
    Jul 9 '20 at 2:57
  • Did work for Linux Mint 19.3 5.4.0-48-generic
    – Yevgen
    Nov 19 '20 at 13:29
  • 1
    Did not work on Ubuntu 20.04
    – Suor
    Feb 6 at 8:17
5

I am still working on this annoying issue (An option should be included on the Input Devices tab to "Force" the input volume to stay where the user wants to set it. This would apply for specific cases where the user knows what volume it needs for a particular app and the auto adjust features does not work correctly for it. Anyway, to set it to "semi-manual" mode instead of auto adjust for Google Apps like Hangouts, created/edit the file options in:

nano ~/.config/google-googletalkplugin/options

and add the line:

audio-flags=1

or simply run the following line:

echo "audio-flags=1" > ~/.config/google-googletalkplugin/options

Save the file and close any Google related apps. The volume for the input device should stop auto adjusting. This works 50/50 this is why I am looking for a permanent solution.

1
  • 3
    The audio-flags configuration option no longer has any effect in recent versions of Google Hangouts, which was upgraded to use the WebRTC protocol. See my answer for explanation.
    – Rufflewind
    Sep 26 '16 at 18:51
5

I fixed the issue on my machine by disabling any other mics on my desktop. I found if the camera mic picked up audio, it dropped the gain on the headset. I disabled the camera mic and the headset is steady now.

Not sure if it helps, but thought it worth mentioning.

0
3

I had this problem, but with every type of video chat that I attempted to use on Xubuntu, everything from Google Hangouts to appr.tc would auto adjust my microphone volume. In particular, it seems to boost the volume if any voices can be heard in the background, as if to try to make the quietest voice be heard.

Anyway, my fix was to manually set my microphone volume with a command line directive, put into a while loop and running every tenth of a second. So, here's the shell oneliner that solves my problem:

while true; do amixer -c 1 set 'Mic Boost' 0db > /dev/null; amixer -c 1 set 'Capture' 35db > /dev/null;  sleep 0.1; done;

On your computer to get it to work, you may need to change which device to adjust and which channels to change. To find that information, you may want to use Alsa mixer, accessible with alsamixer.

0
2

I got this problem with Skype, you have to disable the auto adjust mixer levels (maybe you have to check advanced settings or thing like that)

-1

If this is a problem only with WebRTC in Chromium, disable WebRTC Echo Canceller by going to "about:flags":

WebRTC Echo Canceller pref

4
  • What happens to echos after disabling the Echo Canceller?
    – Xen2050
    Apr 27 '19 at 8:45
  • 1
    @Xen2050 Actually, my solution here didn't work. Chromium still changed my mic's capture volume (gain)…
    – Geremia
    Apr 27 '19 at 20:10
  • this flag is no longer there in 2021 Apr 1 at 17:15
  • doesn't work on 2021 Jun 11 at 17:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.