I am currently running on LXDE, and I'm curious as to whether there is a way to change the context menu when right clicking the desktop.

I'd like to replace Xterm with LXTerminal.

Is there a config I should change for this?

EDIT: For clarification, to enable the Window Manager context menu, you have to visit desktop settings->Advanced, and click the checkbox for enabling the Window Manager menu.

Screenshot of Context Menu

  • 1
    Could you put up an image of this "context menu"? I'm using Lubuntu 12.10, not just LXDE, and I don't see anything related to Xterm or LXterminal in the context menu I get when I right-click on the desktop. If you have problems with taking the screenshot, you could look here.
    – user25656
    Apr 9, 2013 at 1:46
  • 1
    possible duplicate of How do I edit the menu in Lubuntu 12.10?
    – Panther
    Apr 9, 2013 at 2:30
  • 2
    Op says he/she is right-clicking on the desktop.
    – user25656
    Apr 9, 2013 at 3:29
  • 1
    @vasa1 I added a clarification for the 'Context Menu'. It's actually the Window Manager handling the right click. I'm technically using openbox-lxde
    – cxdf
    Apr 9, 2013 at 22:15
  • 2
    Could you modify the image so that the menu is more visible? Right now, it's isn't legible. Or have you solved your issue? If you have, why don't you post the solution as an answer?
    – user25656
    May 10, 2013 at 6:37

3 Answers 3


Running Lubuntu 15.10 'wily', the path to the xml file which contains the menu options. It may be different for another version, but for those who are running what I am running, this is the location of the file to change the LXDE desktop context menu.

To change the "Terminal" menu item to run the lxterminal, instead of the default terminal, open menu.xml (sudo) and find the following block of code:

<item label="Terminal" icon="/usr/share/icons/hicolor/128x128/apps/lxterminal.png">
<action name="Execute">
  <command>lxsession-default terminal</command>

Change the block to:


Your icon may be located at a different path, depending on your version, but this example is based on my machine, so yours may be different. You can create your own icon .png file, and set the path there, as well.

When you're done, just save the updated file, and then right-click on desktop, and select System->Restart Openbox. Select "Terminal" option under shortcuts, and Vala!

  • This fails to answer the question
    – DnrDevil
    Feb 10, 2016 at 22:56
  • Updated my answer, which I feel now fully answers the question. Feb 11, 2016 at 0:48

The right click LXDE context menu is to be found here:


You can change the applications that come up in the context menu by selecting the menu / Preferences / Default Applications for LX Session.

enter image description here

From this menu you can associate the terminal program of your choice with "Terminal Manager" and it will be opened when you use the context menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.