this is my story: I left my laptop at home connected to the router and with teamviewer on. Remotely I was controlling it about 2 hours, at a specific moment the connection has disapeared. When I came back, the laptop was on and still connected to the router but no internet connection.

  1. The router is fine, if I connect another device it works.
  2. I still can see other wifi networks and try to connect to them.
  3. I was not installing anything new software on it while controlling it remotely.
  4. Nobody touched it.
  5. It was not a power failure, everything was like I left it.
  6. Tried with a life cd, same situation
  7. Ubuntu 12.10 on Acer Aspire 7730


wlan0     Link encap:Ethernet  HWaddr 00:16:ea:a4:17:52  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::216:eaff:fea4:1752/64 Scope:Link
          RX packets:15 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4910 (4.9 KB)  TX bytes:13172 (13.1 KB)


wlan0     IEEE 802.11abgn  ESSID:"Real+"  
          Mode:Managed  Frequency:2.422 GHz  Access Point: 00:18:E7:FA:7F:5F   
          Bit Rate=58.5 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-36 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:35   Missed beacon:0

route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 wlan0   U     9      0        0 wlan0

ping -c4

PING ( 56(84) bytes of data.
--- ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3023ms

Interesting the default gateway ping works, ping

PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=3.05 ms
64 bytes from icmp_req=2 ttl=64 time=6.23 ms
--- ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 3.051/4.644/6.237/1.593 ms

lspci -nn | grep 0280:

07:00.0 Network controller [0280]: Intel Corporation WiFi Link 5100 [8086:4232]

Is this a bad new and I have to buy a new wifi card?

  • How do you know there is no internet connection? The outputs you posted look ok. Try pinging Google like this ping -c4 – mikewhatever Apr 8 '13 at 20:08
  • Only the default gateway ( get pinged, i will add it to the question – micnic Apr 8 '13 at 20:50
  • 1
    Is this by chance an Intel card? lspci -nn | grep 0280 We may need to disable 802.11N. – chili555 Apr 8 '13 at 23:59
  • 1
    sorry to inform you, but I asked this question 7 years ago :D I solved the issue just by reinstalling the system – micnic Oct 8 '20 at 18:23
  • 1
    @WilliamMartens no problem, thanks for helping with this kind of issues, have a nice day too! – micnic Oct 8 '20 at 18:35

Please open a terminal and do:

gksudo gedit /etc/modprobe.d/iwlwifi.conf

A new, empty file will open. Add one line:

options iwlwifi 11n_disable=1

Proofread, save and close gedit. Reboot and let us hear your report.

  • How does this help? – green Apr 9 '13 at 12:26
  • Ideally, it solves the 'connected to the router but no internet' problem. It's a pretty well known bug. If, however, it doesn't help, it's easy enough to simply delete the conf file and troubleshoot further. – chili555 Apr 9 '13 at 12:34
  • unfortunately, this did not help :( waiting for a miracle, are there any other solutions? – micnic Apr 11 '13 at 17:52
  • Are your symptoms the same? Any clues here? dmesg | grep -e wlan -e iwl or here? nm-tool – chili555 Apr 11 '13 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.