14

I recently installed 12.10. When Gimp is launched, its main window extends below the bottom of the screen, and cannot be resized vertically, only horizontally. Also, the toolbox window isn't displayed correctly; it doesn't have a title, nor is it framed. Instead, all the toolbox icons appear in a single column that extends below the bottom of the screen. The problem persists after reinstalling Gimp.

In case it's relevant, I'm having two other graphics-related issues: text in Firefox frequently gets garbled, and the whole system periodically freezes, either for a few seconds or without returning to normal. I'm running Intel integrated graphics (controller i915).

2
  • "I'm having Issues"? Is it possible to be specific in the title?
    – user598821
    Jul 9, 2018 at 23:16
  • 1
    how can this one be the duplicate when it was asked first?
    – Brian D
    Apr 8, 2019 at 15:33

2 Answers 2

21

I was having the same problem with GIMP and fixed it with the following steps:

  1. Go to Edit > Preferences
  2. Click on the Window Management option
  3. Click "Reset Saved Window Positions to Default Values" button
  4. Close GIMP

When you re-open GIMP, all of the toolboxes and window sizes should now be back to their defaults.

As for your Firefox problems, I can only suggest clearing out your cache and making sure you're running the latest version.

3
0

To add to Brian's answer -

You can set GIMP's window-size as you like,
and make it remember this for good:

  1. (Get to a valid window-size, as explained by Brian)
  2. Resize and position GIMP's window to something you could live with as default,
    i.e.: size that is good for your desktop
  3. Open Window Management again
    (Edit > Preferences > Window Management)
  4. Un-check the option [ ] Save window positions on exit
  5. Click [Save Window Position Now]
  6. Click [OK] to close the Preferences dialog

Not the answer you're looking for? Browse other questions tagged or ask your own question.