2

Using MS Office in Wine with some keyboard layouts (e.g. us_international) that involve letters that need the Alt Gr key, I noticed that it does not work. But it turns out the problem affects all keyboard layouts.

All works well in the Linux/Ubuntu text editors (Leafpad, Gedit) and in LibreOffice; I have found the same problem in Notepad, and I imagine it is true for all text editing under Wine. (Even using text in a music player like foobar2000 involves the same problem).

What is the cause of this - and can this be fixed?

I'm using Xfce


I found this problem reported on here on Ubuntu Forums, but I cannot see how the Wikipedia link posted there can help.

3

On a forum in Spanish I found the same problem with an answer saying:

go to Menu > System > Preferences > Keyboard > Layouts there you choose your keyboard and your layout and other options such as using the AltGr, then you hit Apply System Wide.

In Xfce I could not replicate the exact steps, but what I did was:

Under Menu > Settings > Keyboard (that is xfce4-keyboard-settings), under the Layout tab, I unchecked Use system defaults, selected the keyboard layout, and then set Alt Gr under Compose key.

keyboard settings dialog


After a while, even without logging out, this solution stopped working, so I looked at the Keyboard Layouts properties (the Xfce panel keyboard applet, xfce4-xkb-plugin) and made the same setting there. Now it works even if the previous setting (in xfce4-keyboard-settings) is removed.

The two settings seem independent, but the one that prevails in Xfce is that of the xfce4 panel applet. (The same is true for switching layouts: Alt-Shift was set and working for a long time in the xfce4-xkb-plugin while in xfce4-keyboard-settings this setting was absent. -- I leave the first part of the answer for reference and for possible use in other desktop environments.)

keyboard layouts dialog

(In Xfce and LXDE, there are cases where different apps are not completely integrated under a unified design, they handle the same or similar features, and it is not always clear if there is possible conflict or whether one prevails. Trial and error is the way here, starting by avoiding conflicting settings.)


On the subject of the two Xfce applications handling the same features, see this question.

| improve this answer | |
0

On Ubuntu 17.10 you can fix this by running gnome-tweak-tool and in the keyboard section activate Super right for compose key.

| improve this answer | |
  • The question is old now, II guess this was fixed in newest versions of Ubuntu and of Wine/Playonlinux. I am not sure about the Ubuntu version, but considering the date I posted, it must have been 12.04 or 12.10. I am sorry I haven't mentioned it at the time. But anyway: the question is clearly indicating Xfce desktop: so, nothing to do with "Gnome Tweak". - Also: this is about RightAlt as needed by us-international keyboard, nothing to do with Super key. - You have minimal reputation as I comment, so I don't need to down-vote this :) -- joking! (I wouldn't have downvoted anyway) – user47206 Mar 16 '18 at 16:11
  • Agreed, very old question and is most likely solved by today's date... – NerdOfCode Mar 16 '18 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy