This question already has an answer here:

I bought a new computer a couple of weeks ago and installed Ubuntu from a book DVD. Everything went fine and I was happily using Ubuntu until I found out that it was the 32 bit version. I want to use the 64 bit version since I just spent the money to replace my old computer with a 64 bit system. I created a DVD with the 64 bit ISO from the Ubuntu site and installed that. The installation goes fine and says that it completes successfully but when I reboot the system I get a message

error: file '/boot/grub/i386-pc/normal.mod' not found
grub rescue

I can boot from the install DVD and I can see that 64 bit Ubuntu runs fine on my system and have used that to try some of the suggestions I have seen on this site and on google but have not found one that works.

From the grub prompt and from running the Ubuntu dvd I can see that I do have a directory named /boot/grub/x86_64-efi which seems like the 64 bit analogue to i386-pc directory and which has a lot of .mod files in it. To my simple understanding it seems like grub is confused and is looking for its mod files in the 32 bit directory which doesn't exist rather than in the the 64 bit directory which does exist. And then, it seems like if I could tell grub to look in the right place I might be on my way to getting Ubuntu to boot.

Does anybody have a solution for this problem?

marked as duplicate by Zanna, WinEunuuchs2Unix, Kevin Bowen, Elder Geek, Eric Carvalho Jul 29 '17 at 16:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


I resolved this problem.

I did two things and have no idea which of them was the one that solved the problem.

I had 2 disks on the system. One was a solid state drive and the other was a traditional mechanical hard disk. I unplugged the solid state drive.

Then I reinstalled from the dvd. When I got to the part where I partitioned the drive I set up the partitions I wanted and then selected continue. The installer responded with a warning that I had not set up an efi boot partition and one of at least 35 MB was required. I went back and added a 40 MB efi boot partition. (This is one of the options in the partition type selection list and is not the same as /boot) The installation completed and I rebooted and the system loaded and is running just fine.

That efi boot partition warning never came up during the 3 previous times that I tried to install Ubuntu on the SDD. So I don't know if the problem was in installing the 64 bit version on the SDD or the fact that I didn't create a efi boot partition. I do know that the 32 bit version installed and ran from the SDD.

I am knew to this forum and don't know how to close a ticket and I don't see a button to do that on this page. But if someone wants to mark this as solved, that is fine with me. I consider it done.

  • 1
    Only you, the asker, can select a best answer. There should be a check mark you can select to the left of your answer near where you upvote/downvote the answer. If you are satisfied with your answer then select it as the best answer. – Nil Apr 7 '13 at 16:54

error: file '/grub/i386-pc/normal.mod' not found try the answer on this link you will surely solve it. It always works for me, either it is linux mint or ubuntu

Not the answer you're looking for? Browse other questions tagged or ask your own question.