20

In the Mouse preferences dialog I've set the acceleration to max and the sensitivity to min and the mouse pointer is not exactly sluggish, but I'd like to make it even faster. Is it possible to be done by setting some value in the procfs or something?

Thanks!

3 Answers 3

21

The xset command allows you to change quite a few aspects of your desktop, including mouse acceleration.

xset m 2 1

The first number is the acceleration, the second is threshold. So, in the example I provided, the mouse will go 2X as fast once it's traveled 1px across the screen. Zero has some special connotations, so I'd stick with 1.

I wouldn't think you would need to set the acceleration too high to get what you're looking for.

This effect will disappear once you reboot/restart. If it works for you, the command can be added to your "Startup Applications" to be applied automatically.

Good luck!

12
  • 1
    Set it to 16 1 and is working splendidly now! Thanks! Feb 24, 2011 at 13:10
  • 3
    Wow, you weren't kidding when you said you wanted it fast! :)
    – Windigo
    Feb 24, 2011 at 22:12
  • 1
    I needed to slow my mouse down, so I used xset m 6/5 0. @AlbusDumbledore you're a cyborg. I could hardly click on my terminal window with that setting!
    – lgarzo
    May 24, 2012 at 14:30
  • 1
    @guettli The following question might help: askubuntu.com/q/814/6016
    – Windigo
    Oct 21, 2017 at 0:04
  • 5
    It doesn't work on ubuntu 18.10
    – Elie G.
    Jan 26, 2019 at 2:28
4

There is a number after which the speed isn't increasing.

After this number I've set it to 30, and 200 and the speed is the same. It's still slow, but it is faster than it was before.

I guess it depends on the mouses DPI. The Steelseries Sensei has the most DPI: 16000 DPI. A higher DPI is always better once you know it, but it isn't really that fast when you have one or more 4k monitors.

0

I was looking for the same thing on Ubuntu 23, and found a solution, using solaar The only way I was able to install it and correctly detect my mouse was using a system-wide pip installation with:

sudo apt update
pip3 install evdev python-xlib
sudo pip3 install solaar

After that, I needed to start it with sudo solaar because otherwise my mouse was not detected. Finally, I just increased the Sensitivity settings in the GUI and had a much faster mouse speed than with the system settings limit. Probably not the best way to do it, but it worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .