2

I don't manage to get sound working on my Ubuntu 12.10. The output of my alsa-info.sh is located here.

I would appreciate any help to fix this problem!

1
2

For what it's worth, I've just resolved a no-sound problem on my HDA Intel PCH card: I ran 'alsamixer' in a terminal and unmuted the 'Line' column (with the M key).

Other info:

  • I also made sure to unmute the Master, Headphone, Front, Surround, Center and LFE columns, but it's only when I unmuted Line that sound got out.
  • The 'Chip' line in alsamixer says 'Realtek ALC887-VD'.
  • The sound software never complained about the sound device.
  • My system is Ubuntu 12.04. The speakers are connected to the green connector at the back of the PC.
  • I tested the speakers with another computer.
1

I had this same problem on my Asus K55A laptop, and I fixed it by doing the following:

open terminal and:

sudo nano /etc/modprobe.d/alsa-base.conf

at the end of the script add this line:

options snd-hda-intel model=pch position_fix=1

ctrl+x to exit

When you try to exit it will ask yout to save, enter "Y" then "Enter"

It will then ask you what file name you want to save it as, Do Not Change It!! Just hit "Enter"

Restart your machine and you should be good to go!!

1
  • I think you mean :wq to exit in vi. Ctrl-x is going to decrement the number under the cursor in vi. Ctrl-x is for exiting nano. Since this is an Ubuntu site I've gone ahead and edited your post so it uses nano. – deltaray Apr 8 '14 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.