I tried Ubuntu on my Nexus 7, and I now want to restore android on it. I made the procedure described, in https://wiki.ubuntu.com/Touch/Install and the Ubuntu flash worked well.

But when I want to restore android, the nexus 7 isn't detected by fastboot anymore. Everyone's talking about drivers problems, but since i successfully flashed Ubuntu on the Nexus, i assume to have the fine drivers.

I tried on windows too, and the Nexus isn't recognized.

I made a wipe data/factory reset, then my nexus don't have a system anymore, and all I can do is stay in bootloader but my Nexus isn't recognized. I can't flash anything if the tablet isn't recognized.

Do you know what can cause the fact that my tablet isn't recognized after having flashed Ubuntu.

I am on Ubuntu 12.10, and tried several USB cables.

further info :

lsusb returns nothing :

z$ lsusb                                                       [13-04-08 23:46]
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth
Bus 001 Device 004: ID 13d3:5122 IMC Networks 
Bus 002 Device 003: ID 046d:c52e Logitech, Inc. 

still, a unkown device is seen on windows... still searching the whole internet for a clue, but anyone seems to have the same problem...

Seems like it has destroyed my sweet nexus =( any clue would be greatly apreciated.

Thanks by advance

  • Is the USB cable connected properly? Try connecting it to a different port. Also, remove it, run dmesg and then insert it and run dmesg, look if any change has occurred – Amith KK Apr 9 '13 at 4:23

I have solved my problem!

I have tried on another windows, on another computer. I never could completely remove the drivers on my computer... don't know why and spent hours ont it... was on windows 7.

It worked on an old XP windows. I achieved a usb connection in fastboot mode, but still it took me some time to reflash... flashboot was just stuck randomly during the process many times, it took me four hours of wipe/flash of the partitions before getting completed...

A pain in the a**... maybe my tablet has problems with its usb port which is not very stable it seems... well, android is back on, and i'll not try anymore flashing on it =)

Thx anyway to those who took time to think about my problem !


I don't think installing Ubuntu should have touched anything involving the way the tablet identifies itself to a computer over USB in fastboot mode. Its possible the driver you have installed supports connecting the device with a custom recovery or adb, but not fastboot mode. I recommend downloading the Nexus Toolkit for Windows, which has fantastic instructions on installing the proper drivers for different situations, and helped me greatly when I was having similar device recognition issues.


The various builds/firmwares for the Nexus 7 all require different modes to recover and/or re-flash.

Try 'fastboot' mode, 'recovery mode', and 'Ubuntu running'.

Each time wait, until the device is that mode, before inserting the USB cable.

You will see different results for:

sudo fastboot devices
adb devices

With the device usually only responding to one variant at a time ..

For your specific issue.

Nexus 7 should be in 'fastboot' mode (green 'Start' showing).

Attach standard USB cable (not OTG variant)

Verify device is attached:

sudo fastboot devices

Proceed with re-load:

tar zxvf nakasi-4.2.2-jdq39-factory-c317339e.tgz
cd nakasi-jdq39/
sudo ./flash-all.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.