I'm running Ubuntu 12.04 LTS 64-bit, which I installed using the original release (not the newer 12.04.2 release), and have been successfully using netflix-desktop ever since the ppa:ehoover/compholio repository was made available. I never encountered any problems, whatsoever, until a couple of days ago.

It appears that Netflix now requires an update to Silverlight, and I have been unsuccessful in updating Silverlight with the patched wine being used for netflix-desktop.

A screenshot of Netflix Silverlight update message

I'm hoping an update will be available through the repository, mentioned above. Until then, however, does anyone have a solution for upgrading Silverlight?

  • Just a small note: If you are keeping your installation updated regularly you automatically are on 12.04.2 already. The point releases are just updated snapshots of the original release. – Glutanimate Apr 6 '13 at 0:15
  • The kernel versions are different, depending on which release was used in the initial install. Therefore, I thought I should mention it in case that helps in resolving my issue. Thank you... – U53R Apr 6 '13 at 0:26

I found the solution to this problem at the Launchpad page for netflix-desktop.

Erich E. Hoover wrote:

It might be that you started with a profile from before when I had the installer disable automatic updates. So, I would suggest wiping the profile folder to see if that fixes it.

The command to do that is:

rm -Rf ~/.wine-browser

For those that don't like messing with the console, you can just go to your home directory and either click on "View" and check "Show Hidden Files", or just press Ctrl+H, then scroll down until you see the folder labeled ".wine-browser", perform a right mouse-click on the folder, and select "Move to Trash" from the resulting menu.

  • 1
    This solution works for once. Each time you close netflix desktop and run it again, it will still ask for the update. You have to keep doing each time before you use netflix. – The Byzantine Apr 16 '13 at 15:42
  • I had to install wine 1.5.30 and the app broke but, after deleting the profile folder, everything started working again =). – Hugo Jun 17 '13 at 23:14

I don't think it is the silverlight update which does it. It is Firefox update. So press F11 to get into window mode. Then press F10. Go to Options/Preferences ->Advanced-> updates, then disable the automatic browser update.

I was deleting wine-browser everytime, but this fixed it.

  • F11 doesnt work for me. – dwaynemac Jun 2 '13 at 6:01

I was having a problem identical to what you describe and deleting the ~/.wine-browser directory solved the problem for me.

Open terminal and use this command:

rm -Rf ~/.wine-browser

This problem is discussed in more detail at Launchpad which has a section devoted to Netflix Desktop.

protected by Community Apr 14 '13 at 18:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.