1

I am trying to compile a code package, which makes use of cblas and Lapack. Thus, after specifying the path of Lapack and cblas in its makefile, when I try to make or compile, I get the following error

   undefined reference to symbol 'dgemm_'
    'dgemm_' is defined in DSO /usr/lib/libblas.so.3gf so try adding it to the linker        
    command line

If anybody has faced this error earlier, can you please tell me how to resolve it? I tried to search and ended up here,

    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=620434

I dunno if this is the right direction, but please help me out here. Am just stuck, trying to compile few codes. The major thing I want to know is how to do this -

    'dgemm_' is defined in DSO /usr/lib/libblas.so.3gf so try adding it to the linker        
    command line

Its just my thought, but will this solve the problem? Please help me.

  • Did you try linking with BLAS by using -lblas? The static BLAS library should be part of the package libblas-dev – Matthäus Brandl Oct 24 '13 at 0:03
  • hi, i had same error. – stackprogramer Dec 18 '16 at 17:36
  • hey @stackprogramer. I guess I solved it, but do not remember now how I did that. Can back track if you want. – Lakshmi Narayanan Dec 21 '16 at 8:56
  • can you share your solution thanks if you remembered – stackprogramer Dec 22 '16 at 8:51
  • which package are you trying to compile? I was doing this for bundler . – Lakshmi Narayanan Jan 2 '17 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.