3

I am using Ubuntu 12.10 32-bit.

The machine detected the network printer Canon MF4800, but it can not find a driver. The screen prompts for a driver. I selected Canon but I cannot find the the series of my printer. I went to the Canon website and searched for a Linux driver but drivers are not not available for the Linux OS.

2

There is a PPA for Canon printers

PPA description - Canon printer driver daily

Official drivers of Canon printers and multifunction devices, included versions 2.20 and newer

deb http://ppa.launchpad.net/michael-gruz/canon-trunk/ubuntu quantal main 
deb-src http://ppa.launchpad.net/michael-gruz/canon-trunk/ubuntu quantal main 

|improve this answer|||||
  • unfortunately that PPA only goes up to 14.10 (utopic). But if you have 14.10 or lower, you can install it quickly by running sudo add-apt-repository ppa:michael-gruz/canon-trunk at the command line. I'm not sure which drivers you need to install after that or if the print wizard automatically uses the right one. – Tim Tisdall Feb 29 '16 at 14:03
2

It's possible to get the mf4800 to work in Ubuntu with the following steps:

  1. Get the drivers for the mf4890:

    wget http://gdlp01.c-wss.com/gds/0/0100003440/06/Linux_UFRII_PrinterDriver_V270_us_EN.tar.gz

  2. Install the requisite packages:

    sudo apt-get install intltool libglade2-dev libxml2-dev libgtk2.0-dev libcups2-dev

  3. Extract the tarball and move into the necessary directory:

    tar -xzf Linux_UFRII_PrinterDriver_V270_us_EN.tar.gz

    cd Sources

    tar -xzf cndrvcups-common-2.70-1.tar.gz

    cd cndrvcups-common-2.70

    dpkg-buildpackage -us -uc

    cd ..

    sudo dpkg -i cndrvcups-common_2.70-1_amd64.deb

  4. Repeat for the lb package:

    tar -xzf cndrvcups-lb-2.70-1.tar.gz

    cd cndrvcups-lb-2.70

    Edit the allgen.sh file and at line 37 remove --enable-static --disable-shared

    sudo dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info

    Edit the debian/rules file and add --dpkg-shlibdeps-params=--ignore-missing-info to the end of line 227. Edit debian/compat and make it 5 instead of 4.

    dpkg-buildpackage -us -uc

    cd ..

    sudo dpkg -i cndrvcups-lb_2.70-1_amd64.deb

|improve this answer|||||
  • [reposted from a comment by user343008] This really works. I tried so many things for this without good results. This work I am printing well now. Thanks a lot. Only one thing to pay attention to, on the last step dpkg-buildpackage -us -uc I made for all the .deb files that were in the directory. And install the printer with port 9100. After change on properties socket://192.168.xx.xx:9100 to socket://192.168.xx.xx:515. – karel Nov 30 '14 at 19:33

Not the answer you're looking for?Browse other questions tagged or ask your own question.