2

I've tried installing PES 2013 via wine. It worked, the installation process is finished.

The game doesn't run correctly.

The game reads my VRAM as 128 MB, mine is 512 MB. I think I must install the drivers or something so it reads it correctly?

When I run the game it crashes with a weird error.

EDIT: After installing wine 1.5.27 the game doesn't crash, instead it keeps loading, but nothing happens.

I think the whole problem is with my graphics card, it's read as 128 MB instead of 512 MB. How to install the proper graphics drivers?

  • When I run the game it crashes with a weird error. No-one on askubuntu owns a crystal ball so ... – Rinzwind Apr 5 '13 at 14:55
  • Unhandled exception: page fault on read access to 0x0000000c in 32-bit code (0x01210690). That's the first line. Didn't think anyone would know what to do with such an error log. – user147037 Apr 5 '13 at 15:02
  • I've edited the question. – user147037 Apr 5 '13 at 15:39
  • Close voters: There is no need to close it. It should not be closed as 'off topic' unless wine is now off topic! This question has been answered and the OP has confirmed the solution; it was to do with a setting in wine. – user76204 Apr 6 '13 at 10:49
2

Instead of letting wine detect the amount of video card memory available, you can explicitly set it with winetricks. This can sometimes work, and is a possibility, as is investigating the other graphical tweaks available with winetricks.

You can run the following, for example, to set the videomemory to 512, rather than let wine try to detect the video memory available:

winetricks videomemorysize=512 

It is important to note that this will affect the default WINEPREFIX ($HOME/.wine) only. If you have other wineprefixes, you will have to specify your particular WINEPREFIX; for example:

env WINEPREFIX=$HOME/.otherprefix winetricks videomemorysize=512

You can also use the gui version of winetricks from the applications menu and select the wineprefix and then select change settings. Other options available for setting video memory are:

enter image description here

There is no way to tell whether these settings will work with your system, and you may have to tweak other settings such as shaders, etc. I should refer to the wine appdb page and the winetricks wiki and wine FAQ. You may have to investigate how wine and wined3d is detecting your video card and its capabilities.

It also might be worth reinstalling and using a fresh WINEPREFIX, as that can sometimes solve problems (see my answer here for how to do that), as well as using the current development version of wine from the official Ubuntu wine team ppa.

  • It worked! Thanks. Now the game runs normally. One thing so, it's kinda slower on Ubuntu than on Windows on the same PC. Anything to speed it up a bit? – user147037 Apr 6 '13 at 8:58
  • @user147037 Good! I should accept the answer by clicking the tick near the answer. As to why it should run slower under wine, that is difficult to say, but you could probably alter some in game quality settings or the resolution. – user76204 Apr 6 '13 at 10:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.