Using apt-get to install solr-jetty only gives me version 1.4 of Solr, but I would like to use one of the 3.x versions.

I'm not yet confident enough to do a manual installation (something usually goes wrong or I end up irreversibly breaking something).

Is there a way I can easily install the version of solr-jetty for I want for my version of Ubuntu via apt-get?

As an update to the question, I have tried the PPA in the suggested question, however, it did not work. I am told that this is because it is for a different version of Ubuntu.

This is the error I receive at the end of running apt-get update:

Fetched 2,535 kB in 7s (354 kB/s) W: Failed to fetch http://ppa.launchpad.net/gasol-wu/oneiric/ubuntu/dists/precise/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/gasol-wu/oneiric/ubuntu/dists/precise/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/gasol-wu/oneiric/ubuntu/dists/precise/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I have also tried an installation of Jetty and Openjdk using apt-get, but this resulted in Jetty not starting as a service.

  • Hi Lucio - I've updated the question to clarify the issue with the PPA.
    – James
    Apr 7, 2013 at 21:33
  • launchpad.net/~webops/+archive/solr-3.5/+packages maybe if someone wants to try
    – Mateo
    Apr 7, 2013 at 23:12
  • Can you give the exact errors you get when you try to use the PPA?
    – Seth
    Apr 8, 2013 at 2:03
  • Hi Seth - sorry, I have only just seen your message re errors. I have updated the question to include the details of the errors I'm seeing. I'm afraid I can only take them at face value - my assumption was that the files weren't there, but as I mentioned earlier, I was told that they are intended for a different version of Ubuntu.
    – James
    Apr 13, 2013 at 19:36

1 Answer 1


That's because the ppa is set only to offer oneiric packages.


I have some reserves about why the maintainer did this, instead creating a sole ppa for all ubuntu versions, but ok, to solve your problem you should follow the same steps but changing oneiric for precise:

sudo add-apt-repository ppa:gasol-wu/precise
sudo apt-get update
sudo apt-get install solr-jetty

Of course you should purge and delete the old ppa so you won't get more errors.

Not the answer you're looking for? Browse other questions tagged or ask your own question.