Long story short, my computer got a virus yesterday and when I tried to re-image the computer, I accidentally wiped out Windows. While I'm waiting for a Windows 8 OEM disc to get here in the mail, I decided to tinker around in Ubuntu 12.04 LTS.

I've been teaching myself a little C++ lately, and on Windows, for lack of a better option, I just was using Visual Studio C++ Express 2010. Obviously, I couldn't use this IDE on Ubuntu, so I tried to install Eclipse. I wanted it to be able to compile both Java and C++ applications, so first I installed eclipse-java-juno-SR2-linux-gtk.tar.gz from http://www.eclipse.org/downloads/ (It was the 3rd from the top.) Everything compiled and ran just fine in the Java perspective.

When I tried to install the C/C++ Developer Tools, things started going awry. First I tried installing the plugin from the Help > Add New Software... menu. It said everything downloaded correctly, and after restarting Eclipse, my hello world program failed with the error Launch failed. Binary not found. This error was really cryptic, and didn't even give me an error number, so I tried removing Eclipse and re-installing Eclipse again, this time the option with CDT built in: eclipse-cpp-juno-SR2-linux-gtk.tar.gz, again from http://www.eclipse.org/downloads/ .

This time when everything started up, I tried running a hello world program, but it underlined all of my std's and cout's with an error saying something was unresolved (I don't remember what it said exactly because I have since taken the CDT version back off and re-installed the Java version, which still works fine.

Also, at some point along the way I was having this error: Eclipse Juno C++ error: Program "g++" not found in PATH which I never managed to solve before I uninstalled back to just having Java support.

I could really use some help here, and if you could explain some of the in-depth Linux jargon that you use, that'd be great too as I've only been using Ubuntu for less than 36 hours.

2 Answers 2


I'm not exactly sure why this worked, when I went through the C++ project wizard and got to the final slide reading "Configure the Cross GCC path and prefix", I left the prefix blank and set the path to /usr/bin/g++. Now everything seems to be working!


You seem to be missing the c++ compiler.

in the Ubuntu Software Center, install the package called "build-essential", it should pull automatically all you need.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.