I downloaded ruby on rails on ubuntu 12.10 through this tutorial http://technical-feeds.blogspot.ca/2013/02/how-to-install-ubuntu-and-ruby-on-rails.html.

I did everything and it worked fine.

I checked ruby -v and it came back as ruby 2.0.0p0. I also checked rails, rubygems and git they came back good.

Then I closed the terminal and opened a new one and tried to check the version but this came back for ruby

bimbola@ubuntu:~$ ruby -v The program 'ruby' can be found in the following packages: * ruby1.8 * ruby1.9.1 Try: sudo apt-get install

And this came for rails

bimbola@ubuntu:~$ rails -v The program 'rails' can be found in the following packages: * rails * ruby-railties-3.2 Try: sudo apt-get install

git is still fine though

bimbola@ubuntu:~$ git --version git version


Try and do the following, it might work:

Open a terminal and type:

sudo apt-get install curl


//In order to install RVM

curl -L get.rvm.io | bash -s stable --auto

reload the bash profile:

. ~/.bash_profile

install the following packages:

sudo apt-get install build-essential openssl libreadline6 libreadline6-dev \
curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-dev sqlite3 \
libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison  \
subversion pkg-config

Now install Ruby:

rvm install 1.9.3

then type:

rvm use 1.9.3

make it default:

rvm --default use 1.9.3-p327

Finally install Rails:

gem install rails -v 3.2.9
  • 2
    ahh dude i found out i never put rvm use 2.0.0 --default . – Bimbola Apr 4 '13 at 3:51
  • 1
    all i did was put rvm use 2.0.0 and it worked haha – Bimbola Apr 4 '13 at 3:52
  • 1
    Well, here's the thing, you shouldn't have to tell it to use one of the default unless there is another installed. Sometimes the .bashrc file will have the path set where it won't show up as default. You can always use which ruby to see where it is installed, and change the path if need be. – esnowrackley Apr 4 '13 at 3:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.