14

I'm trying to create a command that will open 3 services from the Rails stack, rails s, spork, and autotest. I can run these commands individually by opening 3 terminals, going to the app folder and running them. I can even open 3 new tabs and run the commands on each.

The problem is that they fail when I try to open the tabs via gnome-terminal like so:

gnome-terminal --tab --title="rails s" -e "rails s" --tab --title="spork" -e "spork" --tab --title="autotest" -e "autotest"

Error (for spork and autotest):

There was an error creating the child process for this terminal
Failed to execute child process "spork" (No such file or directory)

Surprisingly it does work for 'rails s' (the tab shows the server running).

Any ideas?

8

Below is an answer from stackoverflow.com

  1. Add a eval "$BASH_POST_RC" to the end of your .bashrc

  2. Set the BASH_POST_RC environment variable for each tab to that command you like to execute, e.g.: gnome-terminal --working-directory="/home/zardoz/projects/my_rails_app" --tab -e 'bash -c "export BASH_POST_RC=\"rails server\"; exec bash"' --tab -e 'bash -c "export BASH_POST_RC=\"autotest\"; exec bash"'

13

Invoking gnome-terminal three times and stringing the commands together with && won't work, and the tabs won't appear in the same terminal, and indeed you will have to quit the first terminal for the next to appear.

The way to make sure all your tabs open in one instance of gnome-terminal all at the same time is to use the --tab-with-profile=PROFILENAME switch. In the command below you can leave the first command as gnome-terminal --tab as that it is the first window to be generated; now all you need to know is which profile you are using and you can use --tab-with-profile=YourProfile to invoke the other commands and they will all appear at once in the original terminal opened.

Here is your command modified:

gnome-terminal --tab --title="rails s" -e "rails s" --tab-with-profile=Default --title="spork" -e "spork" --tab-with-profile=Default --title="autotest" -e "autotest"

(For future readers: substitute the program names given after -e to test out the command line given here; remember your targets for -e must be installed and in $PATH; for things not in $PATH use an absolute path such as, for example, /opt/mike/program)

Remember to specify the actual profile you are using for the --tab-with-profile switches. The first invocation of gnome-terminal must use --tab and all the rest --tab-with-profile. With this method it should be possible to open a large number of tabs all in the same instance of gnome-terminal.

Find the profile you are currently using by right clicking in gnome-terminal and look at profiles and there will be a marker on the one you are currently using:

enter image description here

Go to Profile preferences for more information and to check the name of the profile.

For more information, see man gnome-terminal and the Ubuntu manpages online.


Note:

If you have trouble launching your programs with gnome-terminal, either add the location to $PATH, or make a symlink and place it in a $PATH location, or (what was very useful here): create a simple bash wrapper script and call that in the gnome-terminal command line above. (You must call it with an absolute path: i.e. /location/of/script and not just the name of it.)

As an example:

#!/bin/bash
cd $HOME/.rvm/gems/ruby-2.0.0-p0/bin 
spork
exit 0

Then name the script, make it executable and call it in the gnome-terminal command line above. Do this for all the non repo programs that are problematic.

  • How do I know the profile? (I tried with Default, my username, and ~/.profile) – Manuel Apr 3 '13 at 17:01
  • It says Default but I get the same error using --tab-with-profile=Default – Manuel Apr 3 '13 at 17:08
  • @Manuel The other possibility is the target commands aren't in your $PATH;specify the location of spork and the others with an absolute path. – user76204 Apr 3 '13 at 17:15
  • The command I'm using is gnome-terminal --tab --title="rails s" -e "rails s" --tab-with-profile=Default --title="spork" -e "spork" --tab-with-profile=Default --title="autotest" -e "autotest" (copy/paste from your answer). About $PATH, if this is the problem then why does it work on a tab opened via the menu? – Manuel Apr 3 '13 at 17:29
  • @Manuel As you say in your question, you have to go to "the app folder" and run them from there, which means they are not in $PATH. The method in the answer is the one I use to launch all repository installed command-line programs in different tabs in the same gnome-terminal window, and it always works, as those other programs are in $PATH. – user76204 Apr 3 '13 at 17:44
0

gnome-terminal --tab -- sh -c "python3 'test.py' ; bash"

this code open new tab in terminal running a python script and when its over, this new tab will not close, because i added 'bash' in the end of this code...

if you want it multiple times, put it into a while loop in your bash script

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.