7

Today when I opened Empathy on Ubuntu 10.10 I got this unusual error box. I have never got this warning about an untrusted connection before.

What should I do? Is it a security risk if I continue without a second guess?

screenshot of the dialog box

3
  • I doubt it's a problem. Does everything work as expected if you click Continue? You have the latest Empathy, and you're using the standard Facebook Chat account setting? (That is, not some kind of Jabber workaround?) ... I just tried it myself and it works flawlessly still.
    – sk29910
    Feb 23 '11 at 16:17
  • I haven't pressed continue yet and closed Empathy right after this warning, Everything else works just great and I have a fully updated ubuntu system. And yes I am using the standard facebook chat account setting nothing else. Feb 23 '11 at 20:50
  • 3
    I would have guessed they let their certificate expire, too, except that if you look at the image, it says the certificate was issued on 2011-2-9 and expires on 2014-2-13, which is still a few years off. I'm getting this error, too, every time I start up Empathy, even if I click on the "Remember this choice for future connections" flag.
    – user13487
    Apr 2 '11 at 20:35
4

There is a bug open on Launchpad relating to the DigiCert certificates not being installed:

https://bugs.launchpad.net/ubuntu/+source/ca-certificates/+bug/742889

If you're seeing this issue, please mark the bug as affecting you; it may help expedite a fix.

0
4

They let their SSL certificate lapse, while funny, not really a big deal with facebook. If it were say your bank you should back off. This was quite in the news but happened. No worries though. As you can see here it is not the first time they let it happen http://www.liewcf.com/facebook-ssl-certificate-6695/

4

The problem is not that it is expired. The problem is that it is self-signed and Empathy does not recognize the issuer as a Certificate Authority.

My problem is that I check the box "Remember this choice for future connections" and click Continue, but I am still prompted every time I log in.

1

I found this article.

The solution was to export DigiCert High Assurance CA-3 from firefox preferences

Edit > Preferences > Advanced > Encryption > View Certificates > Authorities

Save as DigiCertHighAssuranceCA-3.crt

Copy to /usr/share/ca-certificates/mozilla (file owner should be root)

Run sudo dpkg-reconfigure ca-certificates and check all certificates including DigiCert High Assurance CA-3 which were previously unchecked.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.