I try to install ubuntu 12.04 on my computer. I can get to the purple screen on the live cd but then, if I choose "Installing Ubuntu", I have a black screen with a cursor blinking (and nothing else happens).

My PC : acer aspire M3920, CPU i5-2300, 8 Gb RAM, NVIDIA gt 405.

What I already tried :

  • I tried with 12.04 and 13.04 daily build
  • I tried with a live usb and with a live dvd
  • I tried the following boot options : nomodset, acpi=off

I googled a lot and it seems that it could be a graphic card problem. Do you know any other boot options that I could try ?


This is not a duplicate : I've tried all the common boot options (nomodeset, noacpi...) and it doesn't change anything.

With the option "no splash" (instead of "quiet splash"), I can see what happens before the forever-blinking cursor :

[sdg] no caching mode present
[sdg] assuming drive cache : write trough

ata8.00: excetion Emask 0x52 ... frozen
ata8 : SError : { RecovData RecovComm UnrecovData...}
ata8.00 : failed command : IDENTIFY PACKET DEVICE
ata8.00 : status : { DRDY }
ata8 : hard resetting link

Does somebody know what it means ?

N.B. astonishingly, Puppy Linux boots fine (but Debian, Fedora and Ubuntu do not)


3 Answers 3


The original poster solved the problem and reported the solution in an edit:

In fact, it was not a graphic card problem. I had to disconnect the dvd drive and connect it to another free sata connector (I don't really understand why Ubuntu had trouble with this connector and Windows 7 not). After that, everything worked fine.


Nvidia drivers have always been a little sketchy when it comes to working out of the box with ubuntu machines. I had a similar problem with installing 12.04 on my hp laptop. Try booting with the 'nomodeset' option in the grub menu. This post gives a detailed solution on how to go about it. This post might also be helpful

  • I already tried it, but it doesn't work. Any other idea ?
    – IFasel
    Apr 3, 2013 at 11:47

i suggest to redownload ubuntu , sometimes it (iso) got wrong writing.

i suggest to use LINUX LIVE USB CREATOR

it happened alot with me this issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.