4

I have recently defected to Linux from Windows and no regret, almost...

I sort of miss Real Player. I have found that it IS possible to have it installed which I did through Helix Player website, but this version (RP 11 and Ubuntu 12.10) does not even play DVD. I know RP is not supported by Ubuntu, but what does this mean exactly? Is there any way to use Real Player with Ubuntu?

3

Since the RealPlayer 11 package is already available in the ppa:michael-gruz/backports, you can proceed as follows:

  1. Create a personal PPA using your Launchpad account.
  2. Go to ppa:michael-gruz/backports and access View package details > Copy packages.
  3. Select the desired package (say, the one for Natty) and copy it to your personal PPA. Change Destination series to whatever you need (say, 12.10/Quantal). Ensure that Rebuild the copied sources is selected, which will allow the binaries to be built using the available libraries on the chosen distro.
  4. Click Copy Packages.

These instructions are generic and will work for any package that is already available on a Launchpad PPA, and for any distribution currently supported by Launchpad. They can fail, especially if the chosen distribution does not provide a needed library or a specific version of a library.

But it seems to work in this case. For proof of point, check out the realplay that I copied to my testing PPA. You can check that the package was built against Quantal in View package details in the Series column. (This seems to have worked for the i386 build, but NOT for the amd64 one.)

0

You can use Real Player with Ubuntu, the only thing its version 11. To download it, click here.

Choose your needed file. Once downloaded, it will probably be in the downloads folder. Navigate to the downloads folder, and right click the file, and choose open with Ubuntu Software Center, once you do that and software center opens up, just click on install.

enter image description here enter image description here enter image description here

3
  • Thank you so much for your reply. I did exactly this,(as I wrote, I used Helix Player site, but this time through RP site you kindly wrote down) and the end result is the same. the same RP 11 installed and when I tried to play a DVD, a little window shows up and say "incapable of doing that performance". Is yours working? This is funny. If you have any suggestion, please let me know – user145829 Apr 4 '13 at 13:32
  • The link is dead now. I could only find player.helixcommunity.org and player.helixcommunity.org/2005/downloads , but there are no .deb downloads available there. – landroni Feb 28 '14 at 14:21
  • I found out that real doesn't have the file anymore. You can get it from here. I have also fixed the link in the answer. – Mitch Feb 28 '14 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.