So, I installed the xubuntu-desktop package on my Lubuntu netbook, but when I went to login to a xubuntu session nothing happened. The screen simply went momentarily blank and then came up with the original login screen again.

I tried with xfce session and got the same result. I was logging in with my ordinary Lubuntu details.

I did find one thing to try, which I did, which was to reset Xauthority... Not sure what that is but it didn't help anyway.

I haven't really found anything else similar to this problem, so I thought I'd ask here if anyone else had seen or experienced a similar issue.

  • In my case (using Lubuntu 12.04 for a long time, got closed out via usual username:password, but not as guest), changing to lxdm brought the solution. Now I am trying to reinstall lightdm, because I like that screen better... – user200750 Oct 11 '13 at 10:00

Make sure you have enough free disk space.

After making sure permissions are correct on ~/.Xauthority and tmp as Scott Goodgame's answer explains, the next step is to make sure you have enough free disk space on the partition that contains /home (as Scott Goodgame also suggested in a comment).

You're able to log in to a Lubuntu Desktop session, so do so, then open an LXTerminal (Ctrl+Alt+T) and run:

df -h

That will show you each mounted partition and statistics about how much space is on it and how full it is. For example, when I run that on my machine, I get:

Filesystem          Size  Used Avail Use% Mounted on
/dev/sda8            15G  7.9G  6.2G  57% /
udev                997M   12K  997M   1% /dev
tmpfs               403M  900K  402M   1% /run
none                5.0M     0  5.0M   0% /run/lock
none               1007M  2.6M 1004M   1% /run/shm
none                100M   48K  100M   1% /run/user
/dev/sda6           240M   91M  138M  40% /boot
/dev/sda9            31G   29G  112M 100% /home

(I've left out some entries representing external hard drives and network drives, which would primarily serve to confuse matters.)

If you have a separate /home partition listed in the Mounted on column, check if it has enough free space to spontaneously create files. Usually this doesn't have to be very much--20M is usually quite sufficient, but I recommend shooting for at least 50M. (And of course, you'd normally want much more free than that so you can download and create big files in your home directory--but as you can see, I only have a little over 100M, and I haven't experienced any problems.)

If you don't have a separate /home partition, then look at the free space on /.

Whether or not you have a separate /home partition, you can make it so your home directory (/home/username) has more free space by deleting files there. Make sure not to delete anything important though! Your Downloads folder is often a good place to check for files you don't need.

If you don't have a separate /home partition, then you can free space in your home directory by deleting files anywhere in / (so long as the location where you remove them is not inside a mount point for something else--for example, if a separate /boot partition listed, then you cannot free space in / by deleting files inside /boot even though /boot is a child directory if /).

Generally, it is best not to manually delete files in / (unless they're in your home directory and you do not need them). Instead, you can free space in / by uninstalling software. However, much software in Ubuntu depends on other software, so don't press y or click OK until you've read through the list of packages that would be removed alongside whatever you've specified for removal. You can remove packages in the Software Center, the Synaptic Package Manager, or on the command-line with apt-get.

If you do not have a separate /boot partition (I do, as you can see above, but these days most installations do not), then since everything in /boot would then be in /, you can free space in / by deleting files from /boot. Again, don't do this manually. Instead, uninstall old kernels:

You need to uninstall them if you want to free space, not just hide them in the GRUB menu. (Answers there explain both.) Make sure you do not remove all your kernels, because then Ubuntu will not be able to boot, and the fix for that is not very much fun.

  • It's a good idea to keep at least the kernel you are currently running (as told to you by uname -r).
  • It's also advisable to keep one other kernel, both because the one you're currently using could have problems (which you could work around by falling back to another) and because then if you remove one more kernel than you intended, you still have one.
  • If you do accidentally remove all kernels but have not rebooted, you can just install a kernel back with sudo apt-get install linux-image or sudo apt-get install linux-image-generic.

Once df -h shows that at least 50M of space is free on / and, if it is listed, on /home, try logging in to an Xubuntu session again.

Try a different display manager.

A display manager provides the graphical login screen. A problem logging in like the one you describe could be related to a problem with the display manager you are currently using. Unless you're using a very old version of Lubuntu, you're almost certainly using LightDM as your display manager. (You can check the picture in that Wikipedia article to see if it looks like your login screen.)

Since you have Lubuntu installed, LXDE's very own display manager is probably installed. This display manager is called LXDM (though the picture there will not necessarily look just like LXDM on your machine).

To make your system use LXDM instead of LightDM, run:

sudo dpkg-reconfigure lxdm

You should see:

First screen produced by running sudo dpkg-reconfigure lxdm

When you see that, press Enter. (That clicks the OK "button.")

Then you'll be asked to choose between the display managers that are installed on your system. Most likely there will be two choices: lightdm and lxdm. Use the arrow keys to select lxdm and press Enter:

Second screen produced by running sudo dpkg-reconfigure lxdm

Then either reboot (properly from the power icon on the upper-right corner of the screen, or with sudo reboot) to apply the change. Or, if you prefer, apply the change in a virtual console (Ctrl+Alt+F1) by logging in and running:

sudo stop lightdm
sudo start lxdm

When you run that first command, all your graphical programs will be quit immediately, even if they have unsaved work. Any unsaved work will be lost. I recommend simply logging out before switching to the virtual console (though it's the running of the commands, and not switching to a virtual console, that will terminate your graphical applications).

On a virtual console, you can switch back to the GUI manually by pressing Alt+F7. But when you run the above commands, you should be placed back on the (new) graphical login screen automatically.

If you were unable to do any of this because dpkg-reconfigure failed and said lxdm was not installed, then just install the lxdm Install lxdm package. To install it from the command line, run:

sudo apt-get update && sudo apt-get install lxdm

If you install it in the command-line, it should run dpkg-reconfigure automatically. If it does not, you can still run it manually.

Hopefully, if making sure you have enough free space doesn't help, then switching to a different display manager as explained here will help. If it does not, please comment here and add as detailed information as possible to your question about what you did and what happened.

  • 2
    Fixed, Thanks! I had plenty of disk space left, so I tried switching to LXDM... that didn't work, so I thought maybe I am already on LXDM, so I tried switching to LightDM and that fixed it! Thanks again! – Luke Apr 4 '13 at 18:40

This seems to work for me..

sudo chown username:username .Xauthority
sudo chmod a+wt /tmp
  • okay, so I did sudo chown luke:luke .Xauthority in my ~ directory, then sudo chmod a+wt /tmp... but it hasn't made a difference. – Luke Apr 2 '13 at 22:54
  • This site seems to suggest it might be related to the free disk space" esgimusic.wordpress.com/2011/12/07/technical-difficulties – Scott Goodgame Apr 2 '13 at 23:56
  • 1
    Ended up being a Display Manager issue, so switching to LightDM fixed it. Thanks! – Luke Apr 4 '13 at 18:41

Make sure that all files in your home directory, especially files that start with a "." like .Xauthority, but also .bashrc, .profile, .bash_logout etc. are owned by your user.

ls -la

Should tell you all the files with their owners. You can safely use a

sudo chown $USER:$USER ~/.* -R

to set all files' owner/group to you. Then the login via lightdm/sddm/gdm etc should work again.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.