I am trying to install a bitcoin-repote-rpc miner from [http://www.mediafire.com/file/ve608cl5mk1ka3l/bitcoin-remote-rpc-20110227-src.zip] on my laptop running on ubuntu quantal. I need to use CMake to build the project. I have encountered a few errors and I have managed to solve them by installing the dependencies. Now the last bit which I am unable to solve is this error message

CMake Error at CMakeLists.txt:112 (MESSAGE):
  Could not locate BerkeleyDB

I would like to know how to solve this problem. Thanking you in advance.

When I run

  dpkg -l 'libdb*' | grep '^ii'

I get the following packages already installed

 ii  libdb5.1:i386                             5.1.29-5ubuntu2                            i386         Berkeley v5.1 Database Libraries [runtime]
ii  libdbus-1-3:i386                          1.6.4-1ubuntu4                             i386         simple interprocess messaging system (library)
ii  libdbus-glib-1-2:i386                     0.100-1ubuntu0.1                           i386         simple interprocess messaging system (GLib-based shared library)
ii  libdbusmenu-glib4:i386                    12.10.2-0ubuntu1                           i386         library for passing menus over DBus
ii  libdbusmenu-gtk3-4:i386                   12.10.2-0ubuntu1                           i386         library for passing menus over DBus - GTK+ version
ii  libdbusmenu-gtk4:i386                     12.10.2-0ubuntu1                           i386         library for passing menus over DBus - GTK+ version
ii  libdbusmenu-qt2:i386                      0.9.2-0ubuntu3                             i386         Qt implementation of the DBusMenu protocol

And this is the part from the CMakelists.txt which seems to be producing the error

# Use BDB local module

    MESSAGE(FATAL_ERROR "Could not locate BerkeleyDB")
  • Please add more information about your problem. The question is missing link to the source codes of bitcoin miner and you should also post full build log for analysis. If my answer below doesn't help you I will need that information to update my answer.
    – oerdnj
    Apr 2 '13 at 16:18
  • more info has been added. Apr 2 '13 at 17:41
  • You don't get installed packages with sudo apt-cache search libdb, but available packages. Please get list installed packages with dpkg -l 'libdb*' | grep '^ii'
    – oerdnj
    Apr 2 '13 at 17:54
  • I am very new to linux and I need to learn from scratch :) I have run the command and have edited my question to add the results. Please review. Thank you for your kind support Apr 2 '13 at 18:08

There might be two reasons:

  1. (Simple) Do you have libdb-dev and libdb++-dev installed?
  2. If the answer to first question is yes, then the usual reason for failing the builds is non-existent support for newer version of Berkeley DB. You will need to edit the CMakeLists.txt and mangle it to accept libdb-5.1.so or libdb++-5.1.so in case of C++.
  • The Berkeley DB has been solved by installing the libdb-dev and libdb++-dev as recommended. However, I am stuck with another error now. 'Could NOT find CURL' Please advise me the next step. Apr 2 '13 at 18:32
  • Install the CURL dev libraries, don't remember the name, but if you do apt-cache search libcurl dev, it will show you the required package name.
    – oerdnj
    Apr 2 '13 at 18:37
  • Thank you for you kind help. I have been able to go through all these compile errors and the file was finally built. So the original problem has been solved. However, the application file is not opening and when I double click on it. I get this message: 'There is no application installed for executable files. Do you want to search for an application to open this file?' Apr 2 '13 at 20:48
  • I am sorry, but I have no idea. Try running it from terminal by doing <path_to_the_application>/<application_name> (don't know the name of the application) or by doing cd <path_to_application>; ./<application_name>.
    – oerdnj
    Apr 3 '13 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.