I have a program that I simply received as an .exe file. Installation seems to work with wine but it asks to activate the product online. The preset is to use the Internet Explorer settings but as I don't have neither Windows nor the Internet Explorer I am stuck. There is a setting to route the request via a proxy server and port 80 but I have no idea what to make of it.

How do I activate this port to use within wine?

enter image description here

I have tried to uncheck the Use Proxy Server box with the same result:

enter image description here

I opened up a terminal to track what wine is doing, navigated to the .exe file and started it. The activation screen occurs (picture 1). Here is the output:

fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x136a78 (0x156af8) fixme:shell:IShellBrowser_fnOnViewWindowActive stub, 0x136a78 (0x156af8) fixme:exec:SHELL_execute flags ignored: 0x0000000c p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory fixme:process:GetLogicalProcessorInformation ((nil),0x33fdcc): stub fixme:wtsapi:WTSRegisterSessionNotification Stub 0x204d6 0x00000000 fixme:x11drv:sync_window_opacity LWA_COLORKEY not supported fixme:font:RemoveFontMemResourceEx (0x8771dcc9) stub fixme:font:RemoveFontMemResourceEx (0x877df699) stub fixme:wtsapi:WTSUnRegisterSessionNotification Stub 0x204d6

  • 1
    Can you access the activation server if you put the address into a browser? I tried it from here. It's slow but it worked. If that doesn't work for you there might be an actual networking issue. If it does work, then it's probably a bug in Wine. – Oli Apr 2 '13 at 13:44
  • That does work with Firefox and with the Internet Explorer within wine. So it guess it is an issue with wine running the program activation. – Stockfisch Apr 2 '13 at 14:19

Wine probably has installed a version of Internet Explorer 6. You may find it by browsing to the following location (.wine is a hidden directory which can be shown in Nautilus by hitting Ctrl + H:

~/.wine/drive_c/Program Files (x86)/Internet Explorer

There you may find the following icon ready to run by clicking:

enter image description here

Alternatively try to execute it with the following command:

 wine '/home/<username>/.wine/drive_c/Program Files (x86)/Internet Explorer/iexplore.exe'

This will open Internet Explorer in Wine, from where you can access the registration site (hopefully in your locale - shown here is a German locale):

enter image description here

  • Will OP have to install .NET (based on the ASP.Net in your image)? – user25656 Apr 2 '13 at 14:08
  • This does work (it also points me to the German version), however I need to connect to the server with the program shown in the screenshots above (to active it). Maybe I better try with a virtual box. Thank you! – Stockfisch Apr 2 '13 at 14:21
  • @vasa1: they will probably not have .NET installed - at least here it was not installed (just have checked this with winetricks). In case they need it: askubuntu.com/questions/69744/run-net-2-0-applications-for-win – Takkat Apr 2 '13 at 14:23
  • @boo2060: the activation app may need another Windows component to run. Hard to say which one it might be. – Takkat Apr 2 '13 at 14:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.