Background and Problem

My laptop (Lenovo ThinkPad X131e 3372-2VU, running Ubuntu 12.04 LTS) freezes when Ubuntu tries to manage the wireless interface's power.

I had to manually disable wireless power management to prevent the freezes, and it never happens ever since I did.

However, now I use jupiter in order to save battery while not on AC power, and it seems that wireless power management is back on, and the system freezes started happening again.

Is there a way to configure jupiter to not manage wireless interface power? Or is it enough to just disable the power management manually (i.e. jupiter won't turn it back on again)?

The jupiter applet has been doing an excellent job otherwise. It has literally doubled my laptop's battery life. So I'd much rather have jupiter around.


Running iwconfig on boot would show the following, even after manually setting wireless power management off (sudo iwconfig eth2 power off) before rebooting or shutting down:

eth2      IEEE 802.11abg  ESSID:"287LyonSt."  
          Mode:Managed  Frequency:2.437 GHz  Access Point: F8:D1:11:9B:89:81   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Thanks in advance.


2 Answers 2


After research and some luck (there weren't many information on the internet as to how one can fiddle with jupiter configurations), I was able to find my own answer.

If you look into /usr/bin/jupiter, which is written in python, it tells us that jupiter runs all power-management related shell scripts from 2 files in /usr/lib/jupiter/kernel/:

  • battery for scripts run when the laptop is on battery.
  • power for scripts run when the laptop is on AC power.

To stop jupiter from turning on power-management for your wireless interface card, do the following:

  1. Find the line that says: iw dev $WIFI_ADAPTER set power_save on
  2. Change it to: iw dev $WIFI_ADAPTER set power_save off

This directory containg the ubuntu 12.04 lst default power mananager


Inside a "wireless" executable file has logic to enable, disable wireless on AC/Battery or safe more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.