0

I have a Zend Framework installed on my pc and when I add some actions in Index Controller I get a 404 ERROR, but if I write some actions on another controller let's say TestController the file will be sent to browser. My apache2.conf configuration is :

# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the 

# directive.
#

AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being 
# viewed by Web clients. 
#
<Files ~ "^\.ht">
   Order allow,deny
   Deny from all
   Satisfy all

My configuration for etc/apache2/sites-available/default is:

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
    Options FollowSymLinks
    AllowOverride All
</Directory>
<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

My configuration for /etc/apache2/sites-enabled/zendexample.local is: DocumentRoot "/var/www/ZendExample/public" ServerName ZendExample.local

    # This should be omitted in the production environment
    SetEnv APPLICATION_ENV development

   <Directory "/var/www/ZendExample/public">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride All
      Order allow,deny
      Allow from all
   </Directory>

</VirtualHost>

Same code for etc/apache2/sites-available/zendexample.local At comand sudo a2enmod rewrite the answer is: Module rewrite already enabled I give restart and reload commands to apache server.

In the end of post I repeat 404 ERROR appears only on IndexController actions(root path) if I put the same code in other controller(using same model) and implicit create a new folder (test)in scripts everytihing seems go well.

-1

I have the same problem, just install Ubuntu 13.04, previous OS Fedora 19 all works fine, bu this problem! I see that you post this 3 month ago, did you have any solution now?

// To addmins, sory.

I have some solution, OS 13.04 have apache 2.2 last version of xampp have apache 2.4

I install xampp and /index WORK!, I sink the problem is in apache configs, but with I don't now, for me the best solution is to use xampp.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.