My HP TouchPad wireless bluetooth keyboard connects to input service in blueman, but it won't work as a keyboard in ubuntu.

Blueman receives data from the keyboard however when I mash buttons, since the transfer rate goes up to about 5kb/s instead of 0 when idle.

How can I tell ubuntu that the keyboard is a keyboard and it should listen to the input?

Edit: 5/6/13: This is still an issue, and the dozens of various things I've tried over the past weeks haven't helped. Only restarting works (it has this problem after standby).

Edit: 7/4/13: Updating ubuntu to 13.04 fixed the issue for me. The script posted here in the top comments also worked.

1 Answer 1


Updating to 13.04, or using the script on this bug report page both resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.