hi there I'd been looking for the solution but i hadnt found anyone that had the same issue. I'm trying to share a folder but everytime that I tried to do so Nautilus displays me an error. La «red compartida» devolvió el error 255: net usershare add: cannot convert name "Everyone" to a SID. Unexpected information received. Some people received a similar error regarding an invalid directory or regarding a permission denied. Just for the record i have install samba from the software center, since it didnt work I unistall it and reinstall it from the terminal.I've also tried to share the folder runing Nautilus as root but without any success. does any body have an idea that helps me?


I was looking for the answer to why Nautilus won't let me share folders via the gui for a long time. Turns out, you can only share folders which are children of your home directory. You can surely share other folders on the system, but you will find it much easier to simply create your share folders inside the home directory and right-click > sharing options. This assumes you are trying to do a simple samba share.

If you really need to share a folder outside your home directory, I suppose you could mount the folder to a folder within your home directory. This would require a line like the following in /etc/fstab:

/media/Shared/Video/Movies /export/Movies nobootwait bind 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.