9

Yesterday I installed 7zip on Ubuntu 12.04 LTS and I was able to extract a .rar file by using the Archive Manager.

Right click -> Extract Here

Today I decided to reinstall Ubuntu 12.04 LTS. Then I installed 7zip from the Ubuntu Software Center and I tried to extract a .rar file the same way as last time and I see the following:

"Could not open this file type. There is no command installed for RAR archive files. Do you want to search for a command to open this file?"

I know that you can install unrar if you want to extract .rar files using the Archive Manager but I want to know why 7zip worked the last time and now after a fresh install it doesn't.

15

Make sure the p7zip-full and p7zip-rar packages are both installed. It is particularly p7zip-rar that is needed to provide RAR extraction functionality.

You can install those packages in the Software Center, or you may prefer to install them in a Terminal (Ctrl+Alt+T) by running:

sudo apt-get update && sudo apt-get install p7zip-full p7zip-rar
  • Thanks for the help. I installed p7zip-rar and now it works fine. – kalpetros Mar 31 '13 at 0:40
  • The same applies to Ubuntu 18.04. – jnnnnn Mar 5 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.