This might sound odd, but I have a very peculiar graphics driver issue. Basically, I pop the Live CD in, and "try Ubuntu". Everything works fine from GUI animation, to fullscreen flash, to even full-screen 3D graphics.

However, when I install the OS itself, and reboot into it "properly" for the first time, everything breaks. If I stick with open source, I'm unable to use the computer at all, and if I switch to any of the proprietary ATI drivers, usually the OS will be laggy, full-screen flash videos will be black, or 3D graphics will be choppy and glitchy.

It seems as if somewhere in between testing the OS out, and installing/updating it "breaks" the drivers. What can I do to keep them?

I have an ATI Radeon HD 6850 (1GB) graphics card, and I'm running a 64-bit OS.


I had the same problem when installing 13.04. I have a Radeon HD 6670 (TURKS). After installation the desktop was completely black, and even when switching to a terminal (CTRL+ALT+F1) the screen was still black.

I found that the problem may be related with the use of VESA driver during start up. The solution I found involves using the xdiagnose tool, so you will need an X environment running. I was able to install the ATI proprietary driver and in my case this worked fine. Another option may be rebooting in recovery mode and select X failsafe mode. In my case it even worked resuming startup, as it seems to load X using VESA driver. In this case the desktop will run very slow but it can be used for the following steps.

First open a terminal and run xdiagnose as root. This is a small tool to select some additional options for the display driver. Then I selected the following options under Debug:

  • Display boot messages.
  • Enable automatic crash bug reporting.

and the following options under Workarounds:

  • Disable bootloader graphics.
  • Disable VESA framebuffer driver.

The tooltips for the last two options explain that on some systems if the VESA driver is used during start-up there may be problems when switching to the X graphics driver.

After applying the changes and rebooting, the desktop is running with no problems, and "About" screen displays that the graphics driver being used is Gallium 0.4 on AMD TURKS.

This avoids the Ubuntu splash screen to be displayed during start-up. Also I am not sure if all the options selected in the xdiagnose tools are necessary. Some more testing will be necessary.

I am sure there must be a lot of people with this same problem, so I hope this can help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.