0

I have an Acer Aspire 5750G with Ubuntu 12.10.

I have a problem with the brightness shortcut. If I press Fn+Right Arrowand Fn+Left Arrow, the brightness actually changes but not in the right way. On the other hand, when I type in the terminal gnome-control-center screen, I can adjust the brightness in the proper way.

Is it possible to adjust the brightness of the laptop in the right way using the shortcut?

Remark: I found a lot of questions on AskUbuntu regarding brightness issues but here the problem is different; both "Brightness and Lock" and shortcuts work right now, but shortcuts do not work in the right way!

1

Problem solved:

I finally discovered that using the shortcut would have had the effect of XF86MonBrightnessUp or XF86MonBrightnessDown while the effect I want is given by replacing those commands in the shortcuts with xbacklight +10% and xbacklight -10%.

Of course one has to install xbacklight just typing in the terminal: sudo apt-get install xbacklight

I don't know if there are smarter solutions to the problem but this one satisfies me.

0

You can try adding a parameter to /etc/default/grub.

Run this in a terminal:

sudo gedit /etc/default/grub

Search the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And add the parameter: *acpi_backlight=vendor*

It should look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save and close. Then update the grub with:

sudo update-grub

And restart your system to test if it works.

  • I already tried this grub trick and it does not work. It seems that adjusting brightness via "brightness and lock" or via the current shortcut gives different commands to the PC. For example: if I put the minimum brightness using the "brightness and lock" window, the screen becomes completely black; on the other hand the minimum brightness with the shortcut just gives darker black and distort the words and images on the monitor. The variation of brightness using "brightness and lock" window is really much more uniform and I would like to have the same effect when using shortcuts. – Marce Mar 31 '13 at 13:09
0

I am using Ubuntu GNOME 17.04 on an Acer Aspire 5750G and I had the very same problem. Here is how I fixed it somehow.

Run this in a terminal:

sudo gedit /etc/default/grub

Search the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

And add the parameters: acpi_osi=Linux and acpi_backlight=vendor

It should look like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Save and close. Then update the grub with whichever works for you:

sudo update-grub

or

sudo update-grub2

Then restart your system. After these changes I am able to change the screen brightness with hotkeys but the visual brightness indicator disappered unfortunately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.