164

Until now I was using a "traditional" version of Nautilus: that that comes with Ubuntu 10.10. Now I'm using 3.6.3, included with Ubuntu 13.04 (most likely any recent version is equivalent for the scope of my question, anyway).

One major difference between the two is the search-as-you-type behavior: in classic versions of Nautilus, when you typed an input, the file with the closest alphabetical match would become the selected one, the eligible files/folders being restricted to the current directory.

The new behavior is to perform an optionally-global search instead.

Can one configure Nautilus to provide the previous functionality ?

152
+200

Ubuntu 17.10 and 18.04

As the type-ahead search was a Ubuntu-specific patch, it got dropped together with Unity in 17.10. However there is a package called nautilus-typeahead in the Arch repository. Someone took it, compiled for Ubuntu and made a PPA. You can install it by these three commands:

sudo add-apt-repository ppa:lubomir-brindza/nautilus-typeahead
sudo apt dist-upgrade
nautilus -r

There is an issue on Launchpad about bringing this behavior back to official Ubuntu.


Ubuntu 14.04 to 17.04

Since the Ubuntu 14.04 LTS release type-ahead-find was the default behaviour in Nautilus again.

You can use a dconf key to switch between the different search modes:

  • enable type-ahead-find:

    gsettings set org.gnome.nautilus.preferences enable-interactive-search true

  • disable type-ahead-find in favor of recursive search:

    gsettings set org.gnome.nautilus.preferences enable-interactive-search false


Ubuntu 13.04 and 13.10

Nautilus 3.6.X cuts many features from the 3.4 and older versions. Canonical decided to keep using nautilus 3.4.2 in Ubuntu 12.10 because if this even though Nautilus 3.6 was already released. I don't think it is possible to get the old search behaviour in 3.6 but what I did was to install the SolusOS patched Nautilus (also works for Ubuntu 13.04) which includes all the features from 3.4.2 (it really is Nautilus 3.4.2) while maintaining the Nautilus 3.6 skin. I've tested this particular package and it works fine in Ubuntu 12.10 and 13.04.

Alternatively you could install the Nemo File Explorer which is a fork of Nautilus 3.4 that was made due to the Cinnamon dev team being disappointed with Nautilus 3.6, you can get the install instructions here.

Making it your default file browser is a bit more tricky, this blog post worked for me in Ubuntu 12.10 but some users reported the method not to work properly.

There are alternative methods however. See the following question:

  • As a complement, like explained by Fernando, here is a link for installing SolusOS patched Nautilus for Ubuntu 13.04. I checked it and it works fine on my system : webupd8.org/2013/04/… – Raphaël Titol May 11 '13 at 20:26
  • 7
    GNOME in their infinite dictatorial wisdom have seemingly decided that we do not want this preference anymore, therefore it doesn't exist. Thanks again, GNOME. – underscore_d Apr 9 '16 at 21:37
  • 1
    @fernando-domínguez on nautilus 3.24 this option is no longer available. Can you update your answer? (as I have a feeling that this question will have a lot of hits in the near future) – shil88 May 2 '17 at 13:20
  • 4
    I get: No such key “enable-interactive-search”. I got gsettings and also nautilus --version is GNOME nautilus 3.26.0. – Guillaume Chevalier Sep 24 '17 at 23:20
  • 7
    nautilus -r shows Unknown option -r for me on 18.04 so I just did nautilus -q and then open Files from the launcher. Rest all worked perfect, thanks! Back to normal life. – Siddharth Pant Sep 13 '18 at 8:44
18

Ubuntu 18.04 and newer

Well, this issue has motivated me enough to finally check out Ubuntu's PPA submission process; you can find Nautilus packages with the Arch community patch applied here: https://launchpad.net/~lubomir-brindza/+archive/ubuntu/nautilus-typeahead and install it by running:

sudo add-apt-repository ppa:lubomir-brindza/nautilus-typeahead
sudo apt dist-upgrade

ed: PPA now also contains packages for cosmic (18.10) and disco (19.04)

  • Glad you did it! Thank you for this PPA :) – G. Demecki Jun 9 '18 at 18:55
  • 1
    Just tried it on 18.10: nautilus -r responds Unknown option -r – Mene Oct 29 '18 at 14:54
  • 1
    FYI: I've added deb http://ppa.launchpad.net/lubomir-brindza/nautilus-typeahead/ubuntu bionic main as line to my sources and they get hit by apt, but no effect so far on cosmic. Don't know enough about Ubuntu I guess. But thanks for you work! – Mene Oct 29 '18 at 15:14
  • 1
    @Mene - try switching the PPA repo back to cosmic; I've finally figured out what was preventing me from uploading packages for 18.10 - they should be live in a few minutes – lubomir.brindza Oct 31 '18 at 11:19
  • 1
    Back on 18.10 and everything works! – Mene Nov 18 '18 at 13:42
15

In Ubuntu Gnome 14.04, open dconf-editor. Go to
org>gnome>nautilus>preferences.

Check the box next to enable-interactive-search. Restart nautilus

  • Thanks! In order to restart nautilus, either relogin or give nautilus -q and then nautilus -n in the Alt+F2 box. – hytromo Oct 26 '14 at 19:11
  • 6
    this key doesn't exist in nautilus 3.25 anymore. How to active interactive search again ? – mxdsp Sep 9 '17 at 8:27
  • Nice, it combines well with the chosen answer (actually install a Nautilus with type-ahead search) in case I want to disable type-ahead search later. – hsandt Jan 5 at 19:56
4

There is actually a way to get this in Nautilus 3.26 (the current version in Ubuntu 17.10). Which is building your own version from source, using a patch provided by the awesome arch-linux community. Luckily, the great build system in Ubuntu makes this quite easy. Here's the steps. I'll assume you'll be working in ~/bld-nautilus-typeahead. Start a console and do the following:

# install some necessary tools
sudo apt-get install git

# Create your work directory and go there
mkdir bld-nautilus-typeahead ; cd bld-nautilus-typeahead

# Clone the repository holding the needed patch: 
git clone https://aur.archlinux.org/nautilus-typeahead.git

# Make sure the source repositories for the main archives are available:
sudo nano /etc/apt/sources.list

# If the deb-src line for the main repository (usually around line 6) is commented out (starts with a #), un-comment it (remove the #) and save the file
sudo apt-get update

# Install the build dependencies
sudo apt-get build-dep nautilus

# Retrieve the sources for Nautilus
apt-get source nautilus

# Source should now be in the 'nautilus-3.26.0/' folder. Go there
cd nautilus-3.26.0/

# and Apply the patch from arch-linux
patch -p0 < ../nautilus-typeahead/nautilus-restore-typeahead.patch

# Build the package from source
dpkg-buildpackage -rfakeroot -uc -b

# This will take a little time. If everything goes well, the related packages will end up in the parent directory. Go there
cd ..

# and install the required packages
sudo dpkg -i nautilus_3.26.0-0ubuntu1_amd64.deb nautilus-data_3.26.0-0ubuntu1_all.deb

Start a new Nautilus. Type some letters. Experience that feeling of joy that happens whem the file you intended gets selected.

  • 1
    Applying the patch, I get "can't find file to patch at input line 5 // Perhaps you used the wrong -p or --strip option? // Text leading up to this was ... " and an option to choose file to patch. Any suggestions? – Rasmus Feb 20 '18 at 9:43
  • @Rasmus manually entering the path worked for me. If the .patch file references a/some/path enter ./some/path. I'm pretty sure this isn't the smart way to do it but it worked... – 0x539 Apr 4 '18 at 1:09
  • 1
    The answer above for using the Arch patch works, but I had to specify -p1 instead of -p0. – Juraj Apr 27 '18 at 14:53
0

The answer for Nautilus 3.25 and above is it's gone & not coming back unless someone totally rewrites the ubuntu patch & odds of that are extremely slim to none.

It is not something that can be configured in nautilus itself.

0

Not quite what I wanted but the following limits the search to the current directory and is a very lightweight compromise:

# Get the previous setting in case I want to revert.
gsettings get org.gnome.nautilus.preferences recursive-search &&

# Only search the current directory. Do not go deeper.
gsettings set org.gnome.nautilus.preferences recursive-search 'never'

Tested on Ubuntu v18.10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.