2

I've been trying to get a package manager to work behind our company proxy for a whole day now but without any luck. The proxy requires authentication which is my personal email address and password. I tried just about everything I could think of with no luck: From editing /etc/apt/apt.conf with Acquire::http::Proxy "http://user:pass@proxy:port/"; using simply my username, I tried escaping the "@" but no luck. Browser works fine but I don't really need a browser. The system administrator wished me good luck and that pretty much sums up his assistance. So If anyone can help I would really really really appreciate it.

6
  • Try using %40 instead of @ in your mailaddress. Mar 29, 2013 at 15:01
  • Nope. I still get 407 Proxy Authentication Required. Which is right where I started.
    – alxkls
    Mar 29, 2013 at 15:33
  • Are you using apt-get or a gui tool? stackoverflow.com/questions/8987292/… seems to indicate that apt-get should work with this (though he has the @ sign in the password). A 407 seems to indicate it doesn't see use a password at all instead of merely the wrong one. Are you still setting it in apt.conf? Mar 29, 2013 at 15:37
  • apt-get. I have never used the gui tools. Or ubuntu for that matter as I am an rpm type of man. That doesn't really matter though. And yes-I put all that into apt.conf.
    – alxkls
    Mar 29, 2013 at 15:45
  • It might help if you explain what the exact errors are you are getting with the config, and include an example or two in the question.
    – dobey
    Mar 29, 2013 at 16:06

1 Answer 1

1

Take a look at my answer here: https://askubuntu.com/a/424542/251032

PS: I know this is a pretty old question, but since it took me a couple of years to figure out the details of how to use apt with a proxy, it's possible that an answer is still welcome.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .