24

When I ping any local windows hostname from my Ubuntu machine I get "unable to resolve host", but when I ping from a windows machine it works fine. Why would this be? Samba & Miredo are installed

6 Answers 6

29

To ping a netbios name in Ubuntu you need to add wins to /etc/nsswitch.conf. Run:

gksu gedit /etc/nsswitch.conf

And add wins to the line:

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

So it looks like this:

hosts:          files mdns4_minimal [NOTFOUND=return] dns wins mdns4

Save the file, close the text editor, and ping away.

If that does not work, open /etc/samba/smb.conf, and uncomment the "name resolve order" line:

name resolve order = wins lmhosts bcast

after that, restart nmbd smbd winbindd.

6
  • 4
    I added wins but that didn't change anything. However, I noticed that if I add ".local" after some names it works (with or without the wins setting)... Do you know what's going on there?
    – David
    Commented Feb 24, 2011 at 5:38
  • plus in addition to nejode's answer (thanks nejode) I would also check your smb.conf I have added mine to my answer for comparison.
    – Allan
    Commented Feb 24, 2011 at 13:27
  • what you need to verify in the smb.conf is that your workgroup is the same as the one in the windows station
    – Dror Cohen
    Commented Apr 27, 2012 at 17:35
  • 3
    The Paste you are looking for does not currently exist.
    – ulidtko
    Commented Aug 11, 2014 at 13:37
  • @David: That's using the Avahi system to resolve your names, which the mdns4 directives specify. That's a different system than Samba, so if you want Samba to work, you have to keep testing without the .local domain.
    – palswim
    Commented Apr 1, 2016 at 19:37
8

Running apt-get install winbind fixed it for me.

0
7

You may have to install the package libnss-winbind to be able to find windows computers by hostname. Simply installing winbind may not work. See answer.

1
  • Beautiful, worked for me on Ubuntu 14.04. Installing winbind by itself didn't work. Commented Apr 23, 2014 at 16:22
4

Had the same problem, Ubuntu 14.04 trying to access PC with Windows 8. In addition to above recommendation I had to install libnss-winbind

sudo apt-get install libnss-winbind

Source: http://singularo.com/ubuntu-winbind-not-working

1
  • I'm running 18.04 and have been trying to solves this problem for almost a whole day. This was the (last) thing I was missing. Many thanks!
    – AudioDroid
    Commented Jan 15, 2020 at 14:47
2

If you have edited your /etc/nsswitch.conf file and installed winbind already (libnss-winbind or samba-winbind) and still have problems, you may need to disable your NSCD (Name Service Cache Daemon).

1

@Spivot +1

  1. sudo apt-get install winbind libnss-winbind

  2. sudo vi /etc/nsswitch.conf

    edit:

    hosts: files dns wins myhostname

  3. sudo vi /etc/samba/smb.conf

edit:

[global]
wins server = x.x.x.x
name resolve order = host

Reboot for best results, or just:

sudo /etc/init.d/samba restart

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .