Just bought my significant other a shiny new Samsung Q330 13" netbook, stuck an OCZ Agility in it and installed Maverick. Just as a quick aside, this is a devastating combination. Graphics work perfectly and it cold-boots to desktop in about 7 seconds. Very quick.

But (common to laptops) I've got a couple of problems. I'll start with the most problematic and start a new thread for the other.

Like a lot of laptops, there is a Fn (function) modifier to allow some keys to have another purpose. When I tried to alter the brightness of the screen by tapping Fn+Down, it worked but kept on going until it was as dim as it could go. I tapped Fn+Up and it went to the other extreme.

After that the entire keyboard ceases to work properly because the Fn modifier appears to be locked. Additionally, and as a direct side effect, I think, clicking on things doesn't result in a standard result. It's as if control is being held. A reboot is the only thing that seems to fix these problems.

This isn't a problem if you don't touch the Fn key but as there are two of them on the keyboard, an accident is going to happen sooner than later, requiring a reboot (and probably some data loss).

I don't have a lot of experience with laptops (I prefer my hulking great desktop) so this isn't my area of expertise. I'm open to all suggestions, even disabling the two Fn keys until we can find a better solution.

  • 1
    Did you check the bios to see if there is a related option?
    – RolandiXor
    Feb 22 '11 at 14:33
  • @Roland I have now and no, there's nothing about the keys in the BIOS. I should add that it does only appear to be the brightness modifiers that get the Fn keys stuck. But I've found a quicker fix: I can hop into a TTY and restart GDM. Extreme but it works and it's marginally faster than rebooting.
    – Oli
    Feb 25 '11 at 13:58
  • I have also got this issue but on an Advent Roma 3000, I had this issue also on my previous laptop, a Fujitsu-Siemens Li1818. On my current laptop however using the Fn key to change my brightness works fine, it only sticks when attempting to turn the volume up or down.
    – user931
    May 3 '11 at 2:06

I solved this problem by adding the model name to the file /lib/udev/rules.d/95-keyboard-force-release.rules as explained here: Getting function keys working on Samsung RV510 notebook


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.