Using the default driver in ubuntu 12.04 for the Canon ImageRunner Advance C2020i (or iR Adv C2020i) results in black and white only printing. Using the drivers on the canon website prints dummy text or doesn't do anything. I tried different drivers, models and URI (socket and lpd) and it did not resolve the problem.

The printer is hence unusable for color printing.


Using the default Ubuntu 12.04 driver for the C2550 works perfectly and does not require to install any other software or driver. Color printing works.

Full driver name: Canon imageRunner C2550 Foomatic/pxlcolor


I know your question is quite old. I struggled with the same problem. I tried every driver/combination and only greyscale printing......

It turned out that the C2020i printer itself was set to greyscale printing only. The windows driver can override this option, the linux drivers not.

After setting this option on the printer to automatic, Linux printing in color works like a charm with the printer driver from the topic above (Canon imageRunner C2550 Foomatic/pxlcolor). I bet the provided drivers from Canon also work but I didn't tested this.


I confirm. I had the same problem in Ubuntu 16.04 LTS with the Canon C2225i printer. I declared a new printer with the Canon imageRunner C2550 Foomatic/pxlcolor driver provided by Ubuntu instead of the 2020i driver and now color printing works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.