1

I use vmware for my dev work with ubuntu 12.04. I just installed KDE for add my vpn connection, the configuration seems ok.

But I can't find how to connect my interface eth0 with my VPN.

When I try

nmcli con up id "VPN NAME CONNECTION"

I have this error

(process:2604): GLib-WARNING **: (/build/buildd/glib2.0-2.32.3/./glib/gerror.c:390):g_error_new_valist: runtime check failed: (domain != 0)

Error: No suitable device found: no active connection or device.

I read many thread and no one help with my trouble. Anyone have an idea ?

4
  • That error generally means eth0 is not up, not managed by network-manager or has a VPN on it already. Is any of these three conditions true? Mar 28, 2013 at 8:15
  • Eth0 is up How I can check if my eth0 is managed by network-manager ? I don't have VPN on it Mar 28, 2013 at 14:09
  • Did you set it up with networkmanager? Does nmcli con | grep ethernet list it? Mar 28, 2013 at 14:12
  • nmcli con | grep ethernet didn't list any interface. I never user network manager, vmware find automaticly my card Mar 28, 2013 at 14:18

1 Answer 1

0

NetworkManager cannot manage VPN connections on devices it doesn't also manage, so you have two options here

  • Use NetworkManager to manage your eth0 wired connection and the VPN
  • Don't use NetworkManager to manage either, manage them both manually

I'm afraid you cannot mix and match this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.