I have an ASUS notebook with ubuntu 12.10. My external monitor was working fine but after unpluging/repluging it, it's now detected as "unknown" in my display settings, and I don't get any signal on the monitor. However it still works fine with an other monitor at my office, and on the other hand, my monitor still works fine with my desktop PC on windows 7. I've tried chaging the cable, doesn't help. I've tried rebooting, using Gnome Classic instead of Unity, I've checked the things i've installed recently, and I don't see anything that could affect monitors.

Here is the answer for xrandr with the monitor plugged in:

Screen 0: minimum 320 x 200, current 2390 x 768, maximum 8192 x 8192
eDP1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 293mm x 164mm
   1366x768       60.0*+
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1024x768+1366+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

I don't see any information I could add here, but since it was working fine until now and both laptop and monitor are still working individually, this really look strange... Does anyone has any idea what I could try?

Thanks for your attention!

closed as too localized by Jorge Castro, Eric Carvalho, Mateo, user76204, Kevin Bowen Apr 1 '13 at 17:51

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Try to delete ~/.config/monitors.xml with the external monitor disconnected, logout/login and then connect it again. That file should be automatically generated by the system, but to make sure make a backup of it before. – Salem Mar 26 '13 at 20:34
  • Thanks, but that didn't change anything? After I logout/login, I've tried rebooting. No new ~/.config/monitors.xml file had been created, so I changed a few settigns like resolution of the external monitor in the display menu, and a new file has been generated at that point. The monitor remain unknown and the screen stays black. – Michael-A-D Mar 26 '13 at 21:35
  • It stopped working with my office screen now. I just hope it's not an hardware issue. – Michael-A-D Mar 27 '13 at 10:57
  • What is the output of lspci | grep VGA? Also try to reboot with a live cd/usb and see if it works then. – Salem Mar 27 '13 at 11:06
  • lspci | grep VGA answers: 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) And unfortunately I'm not able to boot on a live cd or usb, since this laptop doens't have cd and booting on usb require a BIOS modification that got me in trouble last time. – Michael-A-D Mar 27 '13 at 12:05

I simply put the cable the wrong way...

So if you ever happen to be in the same case, and you are using a mini-DVI to VGA adapter or just mini-DVI, just mke sure you plugged it the right way: the shape of mini-DVI doesn't prevent you for pluggiing it upside down. I think they all have a logo and it should be on top. If you ever plug it upside-down, like below, ubuntu might detect the cable, but won't recognize the monitor.

Not the answer you're looking for? Browse other questions tagged or ask your own question.