I have recently bought a Toshiba Satellite C850 laptop. I've managed to install Ubuntu 12.10 on it and everything works fine (this site helped me installing the wireless driver). The problem is that the brightness of the screen is full, 100%, and I can't adjust it. The F2 key should decrease the brightness but nothing happen when pressed (with or without FN). I searched this site and tried out every answer relevant to the problem. I've tried the grub parameters, the ATI property driver and xbacklight (a friend told me xbacklight wont work in 3.4+ kernels). The result, all failed. I'm really stuck now. If you know a solution please help.

  • Model: Toshiba C850
  • GPU: AMD/ATI Radeon HD 7610m
  • hi just a quick question. i think my laptop is of the same model as yours, what installer version did you use when you installed ubuntu? i tried to install ubuntu with amd64 version installer and it did not work for me. thanks! – ultrajohn Aug 8 '13 at 6:02
  • @ultrajohn same thing for me, have you salved? – Matteo Pagliazzi Aug 19 '13 at 16:39
  • @MatteoPagliazzi, Ubuntu 12.10 installer worked on my laptop. I tried both 12.04 and 13.04 to no avail. Both of them only gave me a flickering screen during boot up. Setting nomodeset did not help either, only removed the flickering but the whole thing freezes after the ubuntu ...... splash, which is before the login screen.. – ultrajohn Aug 20 '13 at 13:56
  • same thing for me, at the end I tried with Ubuntu 13.10 (the unreleased version) and it worked. I didn't tried 12.10 since neither 12.04 nor 13.04 were working I tought it wouldn'd work – Matteo Pagliazzi Aug 20 '13 at 14:20

To solve problem with brightness you have to do the following:


  1. Open up your terminal

  2. Copy and paste the following code into the terminal, and press enter:

     sudo sed "s/\(GRUB_CMDLINE_LINUX=\)\"\"/\1\"acpi_­osi=Linux acpi_backlight=vendor\"/" /etc/default/grub -i
  3. Enter your password when prompted and press enter again.

  4. Now copy and paste the following code into the terminal, and press enter again:

     sudo update-grub
  5. You're done. Now close the terminal, and re-boot your computer.

I had the same problem and it was solved. Please tell me if you have solved the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.