I know there are tons of threads like this and I've tried everything i can think of that has been given as an answer in those threads.

The problem: I select the USB flash drive as my boot device, and it loads a GRUB menu, that says something like "Try Ubuntu without installing" "Install Ubuntu" "OEM Installation". I click any one of them, and I just get a black screen. I can control alt delete to restart, so my PC is not hanging.

If i change UEFI mode to Legacy in the BIOS, then it SKIPS the GRUB menu and goes straight to a graphical ubuntu installer.

I need to install as UEFI as my Windows 8 installation is as such. I can't boot it if it's set to legacy.

Note that Secure Boot and UEFI are different in my bios, I can disable secure boot without disabling UEFI. However, i still get the black screen.

Things I've tried:

1) nvidia.modeset = 0 2) GRUB_GFXMODE = 1024x768x32 3) GRUB_GFXMODE=vga=vesa 4) vga=vesa 5) A different monitor via hdmi 6) A different monitor via vga 7) Different formats of my flash drive EDIT: Some more things i've tried 8) Confirmed md5 is correct 9) Downloaded Linux Secure Remix 12.10, no difference. 10) Tried drm_kms_helper.poll = 0 11) Tried acpi_osi=Linux 12) Tried acpi_backlight=vendor

Nothing works yet.

NONE of these work, I still get the black screen.

My laptop is a MSI GE-70 with the following specs: Intel i7 3630QM Nvidia GTX-660M with Optimus GDDR5 8GB DDR3 RAM OS: Windows 8 installed as UEFI.

I believe this NOT to be a duplicate since I have tried EVERYTHING i can find, and nothing seems to work.

Does anyone have any idea what it could be?


I installed it via legacy mode. I could not get it to install via UEFI.

However, I patched the install once booted, thus enabling it to be booted in UEFI, by doing this:

Converting Ubuntu into UEFI mode

Note: Do not follow this procedure if your computer is already booting correctly. Use this procedure only if you believe you've accidentally installed Ubuntu in BIOS/CSM/legacy mode and you want it to boot in UEFI/UEFI mode.

  1. Start Boot-Repair, click on "Advanced options", go to the "GRUB location" tab.
  2. If you do not see a "Separate /boot/efi partition" line, this means that your PC does not have any UEFI partition. In this case, exit Boot-Repair, then create an UEFI partition (see the "Creating an UEFI partition" paragraph above).
  3. If you see a "Separate /boot/efi partition" line, tick it then click the "Apply" button.
  4. Set up your BIOS so that it boots the HDD in UEFI mode (see the ""Set up the BIOS in UEFI or Legacy mode" paragraph above).

From http://help.ubuntu.com/community/UEFI.


In my HP P6-2481eo machine (AMD A8-5500 with NVIDIA GeForce GT 620), I had to enable "Legacy Support" in BIOS to get Ubuntu 12.04.2 installation started at all. I also had to disable "Secure boot" to get Legacy Support enabled.

If Legacy Support was disabled in BIOS (as it is by default), Ubuntu 12.04.2 EFI setup (or try Ubuntu without installing option) always ended up in black/blank screen despite of all the options/tweaks you mention above.

After changing Legacy Support option to "Enable", I managed to install Ubuntu using normal setup in EFI mode side by side with pre-installed Windows 8. Then I run Boot-Repair to fix Windows 8 startup options in Grub. Now both OSs works in EFI mode.

  • 1
    Disk Utility shows my drive as GPT. Althought I had "Legacy Support" enabled in BIOS, I was still able to select UEFI boot device option when starting Ubuntu setup from CD-ROM drive. So HP BIOS is not strictly either UEFI or Legacy like some other manufacturers seem to have – MarkoB Apr 12 '13 at 9:31
  • marko@HP-P6-2481EO:~$ [ -d /sys/firmware/efi ] && echo "Installed in EFI mode" || echo "Installed in Legacy mode" Installed in EFI mode – MarkoB Apr 13 '13 at 13:11

I had the same problem with an HP h8-1534 machine.

However, event with Secure Boot disabled and Legacy Support enabled, the system would still go to black screen after boot.

I needed to disable "Fast Boot" as well.


For MSI GE60 and GE70

  • Enable UEFI with CSM
  • Disable Suckure Boot
  • Disable Fast Boot
  • F10 save, while install-source (DVD/CD/USB) is connected
  • Look in UEFI setup, under boot you should see your install-source with UEFI marked (otherwise something is fishy with your install medium)
  • boot, and this should work. (tested with uefi grub 2.00 vanilla)

I managed to get back into the BIOS, by plugging my monitor directly into my mother board instead of the graphics card. Hope that helps

  • 1
    That wasn't a problem for the questioner. The BIOS is before GRUB. – Martin Thornton Dec 25 '15 at 18:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.